No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Lync presence status in Outlook Web Access but not in Lync

  • 5 Followers
  • 15 Replies |
  • This post has 1 verified answer |
Answered (Verified) This question is answered

Hi!

 

I have been communicating with users in other companies for over 6 months with success. But recently I lost presence status (and other functionality) from 2 of the companies in my Lync client, but I still see them from my OWA client. Please see the screenshot.

 

  • users in the 2 companies can see my presence
  • users in the 2 companies can send IM to me, but when I try answer Lync times out with a message like "The message cannot be send"
  • I cannot join an online meeting that has been set up from one of the 2 companies
  • I can see presence in Lync for other companies than the 2

The Lync responsible (with good qualifications) in one of the 2 companies have set up logging on their servers and tested with other remote users but cannot find anything wrong.

 

Please take a look into this - when you have got used to using Lync it's like cutting my leg off without it! :-)

 

  • Post Points: 20
Verified Answer
All Replies
  • Hi!

    The problem is now redused to 1 remote company (the 2. company had downtime yesterday).

     

    I'm using Microsoft Office 365 plan P1.

     

    The situation is a little strange because I can communicate with Lync from Outlook Web Access, but not from my Lync client (on neither PC nor iPhone). You can see it at the screenshot.

     

    I had some help to check logs from Lync today, and the result is this:

    11/02/2012|09:36:12.203 120C:12E4 INFO  :: Data Received - 207.46.5.42:443 (To Local Address: 192.168.1.113:49998) 775 bytes:

    11/02/2012|09:36:12.203 120C:12E4 INFO  :: SIP/2.0 403 Forbidden

    ms-user-logon-data: RemoteUser

    Authentication-Info: TLS-DSK qop="auth", opaque="99BCB678", srand="2708D417", snum="90", rspauth="c21c0cedfbae401501c3f5af278915d535bd2cef", targetname="SN20A02FES04.infra.lync.com", realm="SIP Communications Service", version=4

    From: "Per Nilsen"<sip:per.nilsen@tel-it.no>;tag=99a294a1e9;epid=aa71695b12

    To: <sip:arnstein.aas@felleskjopet.no>;tag=8485C55BF8DB9D8C05D7D651B0F642D3

    Call-ID: 0c5c9df85a904bc991963a61650b6101

    CSeq: 1 SUBSCRIBE

    Via: SIP/2.0/TLS 192.168.1.113:49998;received=10.27.46.15;ms-received-port=2623;ms-received-cid=CB2AD00

    ms-diagnostics: 1027;reason="Cannot route this type of SIP request to or from federated partners";source="sipfed.online.lync.com"

    Server: RTC/4.0

    Content-Length: 0

    11/02/2012|09:36:12.203 120C:12E4 INFO  :: End of Data Received - 207.46.5.42:443 (To Local Address: 192.168.1.113:49998) 775 bytes

    Maybe this information helps you see whats wrong?

     

    Regards, Per!

     

    • Not Ranked
    • Post Points: 0
  • Hi Per,

    Based on the information, “SIP/2.0 403 Forbidden” and “Cannot route this type of SIP request to or from federated partners”, these may be caused by Lync Federation between two organizations.

    I would like to know whether the other user in your company encountered the same issue when communicating with the people in the collaboration company.

    Based on the situation, please try the following information.
    1. Try to re-enable the External communications settings about the account via the following route.
    Log into the Admin page> Click Settings under Lync> Click Users>Select the user account>Click Edit User>Uncheck the Communicate with Microsoft Messenger users>Click Save> Then select the Communicate with Microsoft Messenger users>Click Save.
    Please wait for a while to check if it works.
    2. Try to check if the company adds your domain into their federation domain normally. Only federation between two companies work normally, the communication between them will be normal.

    Thanks,
    Ida Qiu

    • Top 25 Contributor
    • Post Points: 0
  • Hi Ida!

     

    I would like to know whether the other user in your company encountered the same issue when communicating with the people in the collaboration company:

    The account I'm having my daily issues is per.nilsen@tel-it.no. I have now tried with another account on the tel-it.no domain with no success. I have tried this from separate PC's.

     

    I have also tried it with another account from Office365 (@aasnet.com). With this account everything worked fine.

     

    The conlusion to this is that it has nothing to do with local setup of PC's.

    1: I have tried to unchek and then check the Communicate with Microsoft Messenger users

    I now lost connection with all my external contacts and the contacts in the "trouble" company could not see my presence anymore.

    When I turned it on again everything was like earlier (but no connection from me to the "trouble" company

    2: The "trouble" company has tried to put tel-it.no in their federation list, but no change

     

    It seems to me that the problem is in one of the Office365 servers that I use to communicate with external users.

     

    I can still communicate from Outlook Web Access with all my contacts.

     

    I'm looking forward to hearing from you again :-)

    Per

    • Not Ranked
    • Post Points: 0
  • Hi Per,
     
    I understand that the federation issue affects the domain tel-it.no only. Given this situation, please change the domain for a problematic account from the custom domain to xxx.onmicrosoft.com temporarily, and then test the issue again.

    Thanks,
    Mindy Pan

     

    • Top 25 Contributor
    • Post Points: 0
  • Hi Ida!

    It worked! Thanks! - I created a user called per@telit.onmicrosoft.com and I suddenly got presence information for the troublesome collaboration domain felleskjopet.no.

    What do we do now?

    /Per

    • Not Ranked
    • Post Points: 0
  • Hi Per,

    Thank you for your reply.

    I understand that we can see the presence information of the troublesome collaboration domain felleskjopet.no when using an account with the default onmicrosoft.com domain.

    Given this situation, please change the new user account from per@telit.onmicrosoft.com to per@tel-it.no and check the federation issue again. This step can help us to confirm if the domain federation issue is related to the custom domain only.  You can refer to the following steps to change the user account.

    1. Log in Office 365, click Admin.
    2. Click Users on the left panel, select a user account, and click Edit.
    3. Click Details, behind User name, select the custom domain, and click Save.

    Thanks,
    Mindy Pan

    • Top 25 Contributor
    • Post Points: 0
  • Hi  Mindy!

    When I tested with per@telit.onmicrosoft.com I created a new user in O365. If I change domain and call it pertest@tel-it.no (I had a user called per@tel-it.no so I could not use your suggested name), I can se presence from users at felleskjopet.no!! This must mean that the tel-it.no domain is OK...?

    I tried to change domain on my ordinary user per.nilsen@tel-it.no to per.nilsen@telit.onmicrosoft.com and then I can also see presence from felleskjopet.no. BUT if i change it back again to per.nilsen@tel-it.no I cannot se the presence.

    Is it possible that my user has been blocked out from felleskjopet.no? (we have tried to investigate it, but we could not find anyhing that blocks)

    /Per

    • Not Ranked
    • Post Points: 0
  • Hi Per,

    Thank you for your prompt reply.

    I understand that the other user accounts that using the tel-it.no domain can communicate with the contacts from felleskjopet.no. Given this situation, let’s try the following steps to troubleshoot this issue:

    Refresh Lync cached endpoints
    ==========================
    1. Locate the local application data folder:
    Windows Vista and Windows 7: %LOCALAPPDATA%\Microsoft\Communicator\<\">sip_address@contoso.com>\
    2. Delete the file that is named EndpointConfiguration.CACHE.
    3. Restart Lync 2010.

    Delete the Crypto RSA key container.
    ===============================
    1. Open Windows Explorer and locate the C:\Users\<User>\AppData\Roaming\Microsoft\Crypto\RSA.
    2. Delete the RSA key subfolder. The name of the RSA key subfolder consists of a long string of numbers and characters. For example:
    S-1-5-21-433994307-1646369186-2100375486-500
    3. Restart the computer and check the issue.

    Thanks,
    Mindy Pan

     

    • Top 25 Contributor
    • Post Points: 0
  • Hi Mindy!

    Nice try :-), but no success :-(.

    Your question: I understand that the other user accounts that using the tel-it.no domain can communicate with the contacts from felleskjopet.no

    Answer: A user created for some days ago works fine (pertest@tel-it.no), but a user created on 25. october does not work (sandra.nilsen@tel-it.no). I have 2 users that doesnt work (per.nilsen@tel-it.no and sandra.nilsen@tel-it.no) and one user that works fine (pertest@tel-it.no)

    I've been communicating with another O365 user (lars.borg at pdata.se) with a similar problem (he has also an open case). He says that his problem startet around 3'oclock on October 31. My problem startet the same day - only 3 hours earlier. This smells like a change of configuration this day...?

    I wrote earlier: "The situation is a little strange because I can communicate with Lync from Outlook Web Access, but not from my Lync client (on neither PC nor iPhone)" - the problem seems to reside outside my PC.

    Is this of any help?

    /Per

    • Not Ranked
    • Post Points: 0
  • Hi Per,

    This is Jay and I am Mindy's colleague. I would like to work with you on this issue.

    Yes. It is quite strange the we can see the presence in OWA but not in Lync for the same users in a remote domain.

    Now that the Lync client is having the issue, I want to have a look at the uccapi log for Lync. Can you help follow the steps below to enable the log and capture it:

    1. Go to Tools->Options.

    2. On the General Tab, check the "Turn on Logging in Lync" option. Click OK.

    3. Quit Lync.

    4. Launch Lync again and logon to your Lync Online Account.

    5. Wait for a few minutes and ensure we can see the presence of other domains that are working.

    6. Make sure the presence is still not available for the problematic domains.

    7. Go to your user profile folder and enter the Tracing folder.

    8. Collect the uccapilog file for Communicator.

    9 I have sent a private message to you with the uploading information. You can upload the log to me through the workspace.

    Should you have any questions regarding the steps above, please feel free to let me know.

    Best regards,

    Jay

    • Not Ranked
    • Post Points: 0
  • Hi Jay!

    The file is uploaded now :-)

    A comment: The other user I mentioned - (lars.borg at pdata.se) - says that his Lync is working OK again.

    /Per

    • Not Ranked
    • Post Points: 0
  • Hi Per,

    Thanks for the information. I have checked the log that you provided. Basically the problem occurs because a 403 Forbidden response returned after the Lync client sent out a Subscribe message for presence information. This issue is similar to another issue reported. And in that post the issue was resolved itself last week.

    From the client log, we can't tell hwere the Forbidden came from and the reason of it. However, the info shall be available on the Lync Online server in the O365 datacenter.

    Please confirm if the issue stil exists for your tenant. If that is the case, I will submit a request to the datacenter and request for the server side log to investigate further.

    Regards,

    Jay

    • Not Ranked
    • Post Points: 0
  • Hi Jay!

    Today everyting seems to work fine again and I haven't done any changes to my client. I have talked to the technical responsible for the trobledomain and they haven't done any changes either.

    So to me it's most probably a change in the Office365 system. I think it would be interesting to check the logs in the datasenter to find the reason for my

    problem. The reason for this is that the problem I have had for the last period has been challenging and I don't want the problems again.

    Regards, Per!

    • Not Ranked
    • Post Points: 0
Page 1 of 2 (16 items) 1|2|