No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Lync 2013 Problems

This question is answered This question is answered

Recently signed up to 10 Midsize Business licences after testing Office 365 for a few months.


We are testing it on these 10 users before quitting Google Apps and rolling out to all 50+ employees (most of the 10 users are new staff for a project so were getting new PCs so made sense testing with them).


Everything is working fine, except for Lync.  


Lync is operating very strangely at times - sometimes working, sometimes not.  The principal problem seems to be with its connection to Exchange.  So contact lists cant be changed.


When Lync is having issues it reports "Lync can't connect to Exchange.  Your contacts list and conversations might have issues."  however during this time conversations ARE saved, but any attempted change to contacts list results in an error message "Cannot add, remove or move contacts or groups at this time.  Please try again later."


Now the strange thing is, I've had Lync running on my desktop just fine last few days (adding contacts and no connection issues reported) however at the same time my laptop wouldn't even update to the new contacts list shown on the desktop client (and Lync Contacts on People using web interface).


As I said before - Conversations are getting saved still in exchange... which indicates to me that it is managing to connect to Exchange servers.


Further Info to help:


Office 365 isnt linked to any on-site exchange servers - I do not have SSO or even DirSync setup.


I currently have 3 domains on the account.   


companyname.co.uk

companyname.com

and the onmicrosoft one setup when trial was started.


My 10 users are using companyname.com as the login to office 365 services, however in exchange I have comanyname.co.uk set as the default reply address.


This is because this is the normal corporate email address and the .com has only been used by IT for testing (and has never been linked to our current google mail servers).   To get their email we are currently just using forwarding on their gmail accounts.  In a few months when the boss is happy we will switch everyone on bulk and change mail servers, and use comanyname.co.uk as the login (and .com will go back to IT only).


thanks


Russell.

Verified Answer
  • Hi Russell,

    Here is a workaround for the situation you’ve provided:

    If the 10 users’ mailboxes still exist in Google. You can achieve the goal by taking the steps below:

    1. Verify the .co.uk domain in Office 365 without changing the DNS records(only need to add a TXT/MX record to verify that you own the domain).
    2. Change all the Office 365 users’ login address from .com to .co.uk. this will let the users send out mails using the .co.uk domain.
    3. Add a .com or .onmicrosoft.com mail address in Office 365 as a proxy address.
    4. Since the MX is still pointed to Google. You can set the forward rules separately for each user to forward the mails from Google to Office 365 using the proxy address.

    For more details, please refer to the “E-mail Address” part in Manage User Mailboxes.

    0 out of 1 people found this post helpful.

All Replies
  • Hi Russell,

    Before troubleshooting the issue, I’d like to confirm the following information with you:

    1. Do all the users encounter the same issue?
    2. On the PC where the issue happens, has Outlook been configured also there?
    3. After sign in to Lync, press Ctrl key and right click on the Lync icon in the task bar, then select "Configuration information" to check if you have external EWS URL there and the EWS status is OK.
  • 1) Most do yes.  3 out of 4 users working just now have this problem.

    2) Yes, outlook has been downloaded along with lync as part of office download for 365, and all have been configured to access their office 365 email.

    3) EWS External URL is set as the same as your example on my desktop.  However on my Laptop this is blank.  On the laptop EWS is set as Not Deployed.

    Thanks.

  • Hi Russell,

    Based on your description, the issue could be related to various causes. To check it, please try the steps below:

    1. Change one of the user’s UPN (UserPrincipalName) from company.com to the default onmicrosoft.com, then log into Lync using the credential and see if the issue can be resolved.
    2. On the user’s PC who encounters the issue, after log into Lync, click the conversation history icon, then click “View More in Outlook…” in the bottom bar, see if you can open Outlook automatically.
    3. In the Lync sign in screen, click “Delete my sign-in info”, then manually type in the credentials and sign in to Lync again. (see the picture below for details)
    4. In the upper-right area of Lync, click the Gear icon to open the Options page. In the Lync - Options dialog box, click Personal. Next to the sign-in address, click Advanced, then Make sure that Manual Configuration is selected, and change both the “Internal server name or IP address” and “External server name or IP address” to sipdir.online.lync.com:443.
    5. Since in the After-Upgrade Office 365, we’re using UCS (Unified contact store) and all the user’s Lync contacts are saved in Exchange, we’ll need to assign both the Exchange Online license and Lync Online license to the user in order to use the UCS feature. You can try removing the Lync license from the user in OAC (Office 365 Admin Center), wait for about 1-2 hours, then reassign the license back to the user to see if it can resolve the issue.
  • Hi Russell,

    I'd like to follow up on the issue, has the issue been resolved?

  • Hi Neo Yu,

    I will perform the requested steps on Sunday afternoon - or Monday when I return to work at the latest - and let you know the results.

    I can tell you, which may help:

    when I changed my default reply-to address in the exchange settings back to company.com (to match the UPN as company.com) then it works fine.  

    I will reply once i have performed your steps.

    Thanks

    Russell.

  • Morning Neo,

    I have followed the steps and here are the results:

    1) I changed my UPN to companyname.onmicrosoft.com and cleared the lync login details and re-logged in.  Lync would not connect to exchange and recover and contact details.

    I checked exchange properties and found that the SIP had changed to onmicrosoft.com but the default email remained as comanyname.co.uk.

    2) Clicking on View More in Outlook, with step 1 complete but not connecting, gives an error message:

    “The email address used in your default Outlook profile is different from the sign-in address used in Lync.”

    As explained above, I have set the default address to my .co.uk address while we trial the system with 10 users – as I don’t want them to have to use a new email address.  However changing the UPN to the .co.uk is not possible as the autodiscover will not work (as the records are pointing at googles email services just now).

    3) Have tried this a few times with no changes in connectivity.  Given the error in step 2, I don’t think this will help?

    4) Carried out Step 4 changing the configuration to manual, no change to the connectivity to exchange.

    5) Have not tried step 5 yet.  Given error message in step 2 I don’t think it will help?  

  • Hi Russell,

    Based on the information you’ve provided, the issue could be related to the cause that the user’s Lync sign in address and Exchange Online mail address are not the same. This will result in the error that Lync user can’t retrieve the contact information from the specific address’s Exchange mailbox.

    To solve the issue, I suggest you change the user’s Exchange Online mail address to the same as the Lync sign in address, then check to see if the issue can be resolved.

  • Hi Russell,

    How are things going?

    Please feel free to post your updates here if you need further assistance.

  • Hi, not exactly resolved.  As explained earlier on because 90% of the company are still using google apps email, the MX / autodiscover records are still setup on my .co.uk domain for routing to google.

    However, I want my 10 office 365 users to be sending email from the .co.uk address while we test and get ready for full deployment.

    It seems that despite using .com to log into the service, lync and exchange wont link up properly using the account info rather than the email address.

    Unless there is a workaround, i dont see how I can fix this until after we change over service in a few months.

  • Hi Russell,

    Here is a workaround for the situation you’ve provided:

    If the 10 users’ mailboxes still exist in Google. You can achieve the goal by taking the steps below:

    1. Verify the .co.uk domain in Office 365 without changing the DNS records(only need to add a TXT/MX record to verify that you own the domain).
    2. Change all the Office 365 users’ login address from .com to .co.uk. this will let the users send out mails using the .co.uk domain.
    3. Add a .com or .onmicrosoft.com mail address in Office 365 as a proxy address.
    4. Since the MX is still pointed to Google. You can set the forward rules separately for each user to forward the mails from Google to Office 365 using the proxy address.

    For more details, please refer to the “E-mail Address” part in Manage User Mailboxes.

    0 out of 1 people found this post helpful.

  • Hi Neo,

    This worked, although to supplement your answer I added in autodiscover SPV and CNAME records to point at autodiscover.outlook.com.   The autodiscover values do not affect our google apps as it uses its own software rather than this to connect to your mailbox.

    With these set, and the steps followed above this is now working.

    Thanks for your assistance.