Lync Error: Lync cannot connect to the Exchange server.

  • Hi All,

     

    I've recently moved one of our domains over to O365 and couldnt be happier. We are getting one error though. After a while, say about a day, Lync doesnt seem to be able to login to Exchange anymore. We get the following error;

     

    Lync cannot connect to the Exchange server. To restore this connection, please try signing out and signing back in. Until the connection is resotred, history, voice mail and Outlook-related features will be unavailable.

     

    If I exit Lync and sign back in again, all is well, it's just a little annoying performing this little ritual. Has anyone else come across this at all? 

     

    Thanks,

     

    -- Kris

  • Hi

       I found a KB link below which relating to your issue

    support.microsoft.com/.../2436962

       I hope it can resolve your problem.

     

    Thanks

    Rock

  • Hi

    When this error apears, hold ctrl and right click on the lync icon in the taskbar and you will see configuration information.

    Copy that info and paste here please and we will se why this happens.

  • Hi Rock,

    I had a look at that kb article and strangely enough I don't have the following key in registry;

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Communicator

    So that's a no go with that article.

    This error is something similar what we had with OCS 2007 R2 in house for a while where we had mismatched NTLM versions between our Consolidated Edges and Directors, I'm sure MS has this right. LOL

    Thanks for the article.

    Kris

  • Heya Tommy,

    Thanks for that, will post it up when it happens next again.

    Cheers,

    Kris

  • Speak of the devil.. it's happened... I have the standard "Exchange Connection Error" appearing in Lync now;

    DG URL Internal;webpoolbl20a01.infra.lync.com/.../service.svc;--;

    DG URL External;webpoolbl20a01.infra.lync.com/.../service.svc;--;

    Quality Metrics URI;sip:sippoolbl20a01.infra.lync.com@lync0a001.local;gruu;opaque=srvr:HomeServer:ZRqD3wHLplOQLj2CdcFHPwAA;--;

    URL Internal From Server;webpoolbl20a01.infra.lync.com/.../handler;--;

    URL External From Server;webpoolbl20a01.infra.lync.com/.../handler;--;

    Voice mail URI;sip:kristof@domain.com;opaque=app:voicemail;--;

    Exum Enabled;FALSE;--;

    Exum URL;;--;

    MRAS Server;sip:sipfed0A-int.online.lync.com@lync0a001.local;gruu;opaque=srvr:MRAS:lpamgRvV3luLcNw-H0oO1gAA;Enabled;

    GAL Status;webpoolbl20a01.infra.lync.com/.../handler;--;

    Controlled Phones;TRUE;--;

    PC to PC AV Encryption;AV Encryption Supported;--;

    Focus Factory;sip:kristof@domain.com;gruu;opaque=app:conf:focusfactory;--;

    Telephony Mode;Telephony Mode Disabled;--;

    Line;;--;

    Line Configured From;Auto Line Configuration;--;

    Location Profile;DefaultProfile;--;

    Call Park Server URI;;--;

    UCS Mode;Lync Server Mode;--;

    Configuration Mode;Auto Configuration;--;

    Server Address Internal;--;--;

    Server Address External;--;--;

    Server SIP URI;kristof@domain.com;--;

    GAL or Server Based Search;Server Based Search;--;

    Local Log Folder;C:\Users\kristof.DOMAIN\tracing;--;

    MAPI Information;MAPI Status OK;MAPI Status OK;

    EWS Information;--;EWS unavailable;

    Inside User Status;FALSE;--;

    Auto Update Download Started;--;--;

    Auto Update Download Completed;--;--;

    Last Auto Update Request;--;--;

    Pairing State;Lync cannot connect to your desk phone because the USB cable is not plugged in. Make sure that you connect the cable.;Enabled;

    Contact List Provider;Lync Server;--;

    UCS Connectivity State;Exchange connection Down;--;

    Connected Lync Server;sippoolbl20a01.infra.lync.com;--;

    Skill Search URL;;--;

    SharePoint Search Center URL;;--;

    EWS Internal URL;;--;

    EWS External URL;amsprd0302.outlook.com/.../WSSecurity;--;

  • Strange

    MAPI Information;MAPI Status OK;MAPI Status OK;

    EWS Information;--;EWS unavailable;

    My EWS says ok, can you open the EWS External URL in your browser and make sure that its in the trusted sites in IE.

  • It works after I auth my session. I can see the WSDL methods being listed on;

    amsprd0302.outlook.com/.../Services.wsdl

    I've restarted my Lync client and compared the working and non working configuration information and here are the differences.

    Broken;

    MAPI Information;MAPI Status OK;MAPI Status OK;

    EWS Information;--;EWS unavailable;

    EWS External URL;amsprd0302.outlook.com/.../WSSecurity;--;

    Working;

    MAPI Information;Lync is in the process of connecting to the Exchange server. This process may take a few minutes. Some features will not be available until the connection is complete.;MAPI unavailable; retrying connection;

    EWS Information;--;EWS Status OK;

    EWS External URL;;--;

    Looks quite bizarre as for the working one, it falls back to web services but there's no EWS external url listed. :-S

    Strange.

    Kris

  • Hi again.

    Is it like this on all of your clients or just on one?

  • I had a problem similar when I was trying to view the conversations history in outlook from Lync. When clicking the link of  "view more in outlook" Lync displayed an error telling me that there was a problem. I solved it disabling the "Personal information manager" in Lync options/Personal and enabling it again.