No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Can't sign in to Lync after changing the username to my own domain

  • 5 Followers
  • 19 Replies |
  • This post has 1 verified answer |
Answered (Verified) This question is answered

Hi,

 

I can't sign in to Lync after I changed the domain part (from @example.onmicrosoft.com to @example.com) of my username. See the image below:

 

 

This is what I've done so far with Office 365 (Small business & Pros):

1. I've created some users and tested the service. Everything including Lync worked as expected.

 

2. I've verified my custom domain example.com for Office 365. I have NOT edited the DNS records at my domain registrar that point traffic to my Office 365 account. At this time I just want to send and reply email from Office 365 with my custom example.com domain and use Lync. I believe that the verification of the custom domain is enough to do these things (but I am not sure as I have not found any explicit instruction about this).

 

3. I changed my username so it uses the verified custom domain e.g. 

pirkka.rannikko@example.onmicrosoft.com -> pirkka.rannikko@example.com

After the change Lync stopped working (meaning that I can't sign in with either of those usernames).

 

4. I changed the the Lync configuration settings from automatic to manual and entered the server names mentioned here: http://community.office365.com/en-us/f/167/p/12783/57879.aspx#57879 which did not help.

 

5. I uninstalled Lync and the Microsoft Online Services Sign In assistant and reinstalled them by downloading them again from Office 365. This didn't help either.

 

6. I've removed the personal certificate as explained here http://support.microsoft.com/kb/2604176 and deleted the cached end points as explained here http://community.office365.com/en-us/f/166/t/14771.aspx. These did not help.

 

7. I've removed Lync license from myself in Office 365, waited for 15 minutes, added the licence back as suggested here http://community.office365.com/en-us/f/166/p/20468/95978.aspx#95978 but it didn't help.

 

So the questions are:

- Do I need to modify my DNS records in order to use Lync with my custom domain?

--- If I don't, what is the problem here and how can I get it fixed?  

--- If I do, where are the instructions how to do that (is this the right one http://support.microsoft.com/kb/2526143 and what on earth does "redelegated" mean)? I don't want to change anything related to how my emails and websites work now. I just want get the Lync working.

 

Suggestion: I think the Office 365 help documentation is not too clear about what features are available without custom domain, with verified custom domain and with custom domain which DNS records have been pointed to Office 365. E.g. I had to Google for 30 minutes to learn that the verification is enough to send and reply email from my custom domain. Improve the documentation and use pictures. Not everyone configuring the service is an IT-specialist.

 

Thanks!

 

 

  • Post Points: 20
Verified Answer
  • Hi Pirkka,
    I know you have added your domain in Office 365 without redirect your domain name server,  after this you have changed your user name from user@domain.onmicrosoft.com to user@domain.com, and you couldn't login Lync Online.
    For troubleshoot this issue, we may try to test Lync Online by setting Lync 2010 to use manual configuration.
    To do this:
    1.In the upper-right area of Lync 2010, click the Gear icon to open the Options page.
    2.In the Lync - Options dialog box, click Personal.
    3.Next to the sign-in address, click Advanced.
    4.Make sure that Manual Configuration is selected and that the configuration values are exactly as follows:
    Internal server name or IP address: sipdir.online.lync.com:443
    External server name or IP address: sipdir.online.lync.com:443

    In this situation, if manual configuration works, we may still need to update our DNS records at our domain registrar. We need to add the required DNS records at our domain registrar before we can use our Office 365 services (Lync Online, Exchange Online, SharePoint Online)with our customer domain(Just answer yes to your question)
    To do this, Log into MOP (Microsoft Online Portal) > Admin >Domains, select our domain and click Manage DNS, we can find all the required DNS records here, and we need to add all those DNS records one by one at our domain registrar.
    For more details information,  please refer to:
    Add your domain to Office 365 without redirecting your name server records to Office 365
    http://onlinehelp.microsoft.com/en-us/office365-smallbusinesses/hh416759.aspx

    We'd appreciate if you could submit a feedback with your suggestion in your post. And if you have other questions when using Office 365, please feel free to post on the forum.

    Thanks,
    Evan Zhang

    • Top 25 Contributor
    • Post Points: 0
All Replies
  • Hi Pirkka,
    I know you have added your domain in Office 365 without redirect your domain name server,  after this you have changed your user name from user@domain.onmicrosoft.com to user@domain.com, and you couldn't login Lync Online.
    For troubleshoot this issue, we may try to test Lync Online by setting Lync 2010 to use manual configuration.
    To do this:
    1.In the upper-right area of Lync 2010, click the Gear icon to open the Options page.
    2.In the Lync - Options dialog box, click Personal.
    3.Next to the sign-in address, click Advanced.
    4.Make sure that Manual Configuration is selected and that the configuration values are exactly as follows:
    Internal server name or IP address: sipdir.online.lync.com:443
    External server name or IP address: sipdir.online.lync.com:443

    In this situation, if manual configuration works, we may still need to update our DNS records at our domain registrar. We need to add the required DNS records at our domain registrar before we can use our Office 365 services (Lync Online, Exchange Online, SharePoint Online)with our customer domain(Just answer yes to your question)
    To do this, Log into MOP (Microsoft Online Portal) > Admin >Domains, select our domain and click Manage DNS, we can find all the required DNS records here, and we need to add all those DNS records one by one at our domain registrar.
    For more details information,  please refer to:
    Add your domain to Office 365 without redirecting your name server records to Office 365
    http://onlinehelp.microsoft.com/en-us/office365-smallbusinesses/hh416759.aspx

    We'd appreciate if you could submit a feedback with your suggestion in your post. And if you have other questions when using Office 365, please feel free to post on the forum.

    Thanks,
    Evan Zhang

    • Top 25 Contributor
    • Post Points: 0
  • Hi and thanks for your reply but the manual configuration did not work. Lync says the signin address was not found. What now?

    By following the link you provided I gather that I need add the following DNS records to my current DNS host:

    Exchange Online: CNAME record
    Exchange Online: TXT/SPF record
    Lync Online: SRV record
    Lync Online: CNAME record
    Lync Online: CNAME record

    Am I right?

     

    And there is no risk (to break anything existing in our DNS records) in creating these additional records?

    • Not Ranked
    • Post Points: 0
  • Unbeliavable! Lync works now for some reason. I didn't change anything since trying out the Manual Configuration...

    Still I'd like get an answer to my latests questions about the DNS records. Thanks!

    • Not Ranked
    • Post Points: 0
  • Hi Pirkka,

    Thanks for your update.

    I would like to answer the question.

    Q: And there is no risk (to break anything existing in our DNS records) in creating these additional records?
    A: Yes, there is no risk to create the DNS records. It will not take effect on current DNS records.

    Best regards,
    Alex Du

    • Top 75 Contributor
    • Post Points: 0
  • Hi Pirkka,

    Did Alex's information help you? Do you need any further assistant on this issue?

    Thanks,

    Evan Zhang

    • Top 25 Contributor
    • Post Points: 0
  • Yes it did. Lync works now without the Manual Configuration as I added the required DNS-records. Outlook still needs to be configured manually as we did not change our MX records. Thanks for the help!

    Unfortunately I also have a new problem :-(

    As I try to access the Sharepoint (team sites or the editor tool of the public facing website) it gives me the basic "Error: Access Denied" screen. I am the original administrator of the account. Has this something to do with the fact that I've changed our user IDs from @example.onmicrosoft.com to @example.com ???

    Can you somehow reset our permissions so that we could access Sharepoint normally?

    • Not Ranked
    • Post Points: 0
  • Hi Pirkka,
    Are you using the original user account that the subscription was set up with?
    For troubleshooting this issue, you may try to re-assign the license in Microsoft Online Portal to see if it works.
    1. Logon to Microsoft Online Portal (MOP) with original administrator account user name and password.
    2. Click users in the left ribbon.
    3. Select the original account user and click edit, remove the license ‘SharePoint Online’.
    4. Sign out MOP, wait at least 5 minutes and sign in again.
    5. re-assign the license to this user.

    If the problem still persists, I'd like if you could open a new thread and we will troubleshoot this issue individually.

    Thanks,
    Evan Zhang

    • Top 25 Contributor
    • Post Points: 0
  • Yes I am using the orginal account, but I have changed the user ID from user@example.onmicrosoft.com to user@example.com.

    I already tried to re-assign the license but it did not help.

    • Not Ranked
    • Post Points: 0
  • Hi Pirkka,

    Thanks for your information.

    In your situation, I would suggest you try the following:

    1. Change your orginal account user ID from user@example.com to user@example.onmicrosoft.com at MOP.

    2. Access the site collection with the original administrator account to grant another account admin rights.

    3. Change your user ID back to user@example.com, access the site collection with the new admin account and assign admin right to the original user.

     

    As this is another issue apart from the original one, if the issue still persists, we'd like if you could open a new thread for further troubleshooting this issue.

     

    Thanks,

    Evan Zhang

    • Top 25 Contributor
    • Post Points: 0
  • Hi Pirkka,

    Any updates on this issue?  Have you resolved this issue or do you need any further assistant?

    Thanks,

    Evan Zhang

    • Top 25 Contributor
    • Post Points: 0
  • Hi and thanks for asking. I haven't tried your latest suggestion yet. Is there any risk in changing the user ID e.g. regarding how my emails work at the moment?

    • Not Ranked
    • Post Points: 0
  • there is no risk I think.

    If you change ID@example.com to Id @examle.onmicrosoft.com, all mails can receive as proxy address. Don't worry

    • Top 200 Contributor
    • Post Points: 0
  • Hi Pirkka,

    As per my test, if I changed my admin account from user@contoso.com to user@contoso.onmicrosoft.com, an proxy e-mail address would be created automatically in ECP (Exchange Control Panel), all the e-mails send to user@contoso.com would be received. It is OK to change your user name for setting up a new administrator, and it's recommended to changed your user name back then.

    If you have other questions, please feel free to post on the forum.

    Thanks,

    Evan Zhang

    • Top 25 Contributor
    • Post Points: 0
  • I tried what you suggested but it didn't help. Can't access Sharepoint.

    • Not Ranked
    • Post Points: 0
  • Hi Pikka,

    In your situation, as those troubleshooting couldn't address the problem, and as the SharePoint access denied issue is different from the original one, we'd like if you could open a new thread with detailes description, our SharePoint engineer will focus on this issue and do more research for you.

     

    Thanks for your understanding.

     

    Best Regards,

    Evan Zhang

    • Top 25 Contributor
    • Post Points: 0
  • I'll create an other thread about this issue as you suggested earlier. Thanks!

    • Not Ranked
    • Post Points: 0
  • Is this the new thread? Did you open it for me?

    The old one is here: http://community.office365.com/en-us/f/166/p/26963/126881.aspx#126881

    • Not Ranked
    • Post Points: 0
  • Hi Pirkka,

     

    This is the old one. And this is page 2 of this thread, to find the previous reply, you may click on "1" under the low right corner of this page.

     

    We couldn't open a new thread for you, but you may open a new SharePoint Administrator related issue by clicking on this link: community.office365.com/.../addpost.aspx

     

    Thanks,

    Evan Zhang

    • Top 25 Contributor
    • Post Points: 0
  • Ok, thanks!

    • Not Ranked
    • Post Points: 0
Page 1 of 2 (20 items) 1|2|