No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Problems with Shared Mailbox and Outlook 2010

This question has suggested answer(s) This question has suggested answer(s)

I am currently adding in the process of adding shared mailboxes for different departments at work. I have successfully added 1 which is accessible online and via outlook (on Mac osx, although the shared box does not show up as a separate account, all mail is sent straight to their personal mail). 


The other account is inaccessible from Outlook on Windows 7 using Outlook 2010. Currently when we add this to a user the shared box is added but, as soon as you click to open it a message "Cannot display the folder. Microsoft Outlook cannot access the specified folder location." is displayed. This mail box is accessible through the web client.

All Replies
  • What process did you use to setup the shared mailbox? Are you guys using SSO?

  • Hi Jon,
    As I understand, you have added a shared mailbox for a user. The user can open this shared mailbox through OWA (Outlook Web App), the shared mailbox can be added at Outlook 2010 client on Windows 7, however the error occurs when you tried to open it. Am I correct?

    As you can open the shared mailbox from OWA, based on my experience, the issue you encountered should be a client side issue.

    To narrow down this problem from client side, I suggest try the following things:
    1), Run desktop set up for Office 365 and update your Outlook client with the latest service packs.
    2), Delete your account from Outlook client and reconfigure it. You can refer to Set Up E-Mail in Outlook 2010.
    3), Create a new Outlook profile for the testing. You can refer to the following article to create a new Outlook profile for testing:
    http://support.microsoft.com/kb/829918
    4), Turn off Cached Exchange mode of Outlook client for the testing.
    To do this, in the Outlook client, click File on the top; click Account Settings and select Account Settings; double click on your account, unselect Use cached Exchange mode; click Next.
    For more details, you can refer to Turn on or off Cached Exchange Mode.

    For more reference, please refer to Set Up a Shared Mailbox.

    Thanks,
    Evan Zhang

  • The problems stated in the first post were encountered by multiple users, also when I removed my account and tried to add it back to outlook / mail accounts my account could not be found / a server could not be found. This is using the auto account setup.

  • I setup both Shared Accounts using the gui tool and then power shell to add permissions.


    Now when I try to add my mail to outlook manually I get:



    Same if I check the Use Cached Exchange Mode

  • Hi JonConley,

    Thanks for your update. In your situation, I suggest you check if the permission is correctly assigned using PowerShell.

    1. Connect to  Window PowerShell.
    2. Run the command below to check the permission:
    Get-mailboxpermission –Identity “the shared mailbox” –user “user's email address”

    In addition, If you have grant full access to a security group, please make sure you have been added to the security group.

    For more information, you can refer to Create Shared Mailboxes with GUI-based Tool.

    Thanks,
    Evan Zhang

  • Hi JonConley,

    Any updates on this issue? In addition, do you have any other questions? If so, please feel free to respond.

    Thanks,

    Evan Zhang