No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Can't view Shared Folder subfolders in OWA, and Shared Folder doesn't fully sync with Outlook 2010.

  • 7 Followers
  • 9 Replies |
  • This post has 0 verified answers |
Not Answered This question is not answered

Office 365 E3 with 6 users.  Attempting to migrate Public Folders to new Shared Mailbox. Created Mailbox and Security Group, all with correct domain, in powershell per very good directions in other posts.  Able to open Other Mailbox in OWA main account, but it only shows Inbox with no subfolders, no ability to create subfolders either.  If I actually open the other user's mailbox, I am able to see the full directory, inbox and all subfolders, but not from inside my own mailbox.  In Outlook 2010, the mailbox shows up as a share, but doesn't really sync.  If I add folders to it, they don't appear from inside Outlook 2010, but if I go back to OWA and open that shared mailbox as a user, I can see all the changes that were made.  I suspected that there might have been an error in the setup of the original Shared Mailbox and did the process all over from scratch, carefully following each step, but with the same results.  I have also repaired the OST file from the control panel.

 

This company NEEDS this functionality to work, as ALL client work is performed inside the former Public Folders.  I need help getting this solved ASAP!

Thank you in advance!

Jim Bachaud - jim@excel-r8.com (Office 365 partner) 

- you can also reply so Simone at sbachaud@knowledgeintegration.net - my wife and client.

 

 

  • Post Points: 20
All Replies
  • Hello Jim,

    Thank you for your post.

    Per the previous post, I understand you encountered the following two problems.

    Problem 1, Able to open Other Mailbox in OWA main account, but it only shows Inbox with no subfolders, no ability to create subfolders either.

    Problem 2,  In Outlook 2010, the mailbox shows up as a share, but doesn't really sync. If I add folders to it, they don't appear from inside Outlook 2010, but if I go back to OWA and open that shared mailbox as a user, I can see all the changes that were made.

    To help to troubleshoot the problems, would you please try the following steps and check what happens.

    1. Make sure you have granted FullAccess right to users on shared mailbox. You may connect windows powershell to Exchange Online and run the following command to check it.

       Get-MailboxPermission alias of shared mailbox

    2. Clean the option "use Cached Exchange mode" from Outlook client.

    3. Create a new test sub-folder from Outlook client under Inbox of shared mailbox.

    4. Access your mailbox via OWA and open shared mailbox referring to article Open Another Mailbox.

    If you encounter any error, for example, fail to open shared mailbox or subfolder, please post back a screenshot of error message to allow us understand the probelm in more details.

    Additional Information
    ================
    Set Up a Shared Mailbox
    http://help.outlook.com/en-us/140/ee441202.aspx

    Thank you.
    Jack Sun

    • Top 50 Contributor
    • Post Points: 0
  • Problem 1 is still unsolved.  I can view everything if I open the other user's folder from the right side of the OWA client window, but not if it's open in the directory tree of the client's normal email account.  In the normal directory tree, I can only see the shared mailbox's Inbox, but no subfolders and no ability to create them.

    Problem 2 is gone.  YAY!  THANKS JACK!  To make this really clear:  In Outlook 2010, go to File > Info > Account Settings > (Choose your 365 account in question here) > Change... > right under the Server information is a checkbox for "Use Cached Exchange Mode".  Clear that checkbox and everything in the shared folder in Outlook now synchronizes with the Exchange server.

    My only question about the Cached Exchange Mode is that I thought it was recommended to use that setting to minimize web traffic.  Is it fine to leave it unchecked for the long term?

    Thanks again Jack!  Still looking for resolution to Problem 1.

    Jim

    • Not Ranked
    • Post Points: 0
  • Hello Jim,

    Thank you for your update. I am glad that new folders can be synced to Office 365 immediately after clearing cached exchange mode. Meanwhile, to make sure user have best performance when using outlook client, you can configure cached Exchange mode for user again. And the view of folder list in Outlook client will be synced with Office 365 regularly.

    For the problem that user cannot see subfoler under Inbox of other mailbox via OWA. Did you open the Inbox folder of other mailbox by clicking option "Open Other User's Inbox..."? If yes, it's normal behavior. When choosing the 'Open other user's Inbox' option, by default the Inbox is the only folder that appears. The easiest approach would be to open up another user's mailbox by clicking on your mailbox name in the top right of the OWA window.  That way you can see all folders and sub folders of the mailbox to which you have Full Access to.

    Thank you.
    Jack Sun

    • Top 50 Contributor
    • Post Points: 0
  • Hello Jim,

    Did the above reply answer your questions? If you need additional information on this problem, feel free to let us know. Thank you.

    Jack Sun

    • Top 50 Contributor
    • Post Points: 0
  • Hi Jack,

    I've been working on a similar case, and even though it works as you sugested it feels more like a workaround than solution.

    Are there any security reasons for not  being able to show subfolders or is it just a missing feature?

    Thank you.

    Stian H. Nesbø

    • Not Ranked
    • Post Points: 0
  • Hi Stian,

    I understand that you have encountered similar issue. if you have tried the information above and could not help, I would suggest you post a new thread about the detailed information of the issue you encountered and the steps you have done to resolve it, this is so we could focus on your questions and provide more specific solutions for you.

    Thanks,

    Ray Yang

    • Top 50 Contributor
    • Post Points: 0
  • Hi Ray,

    Thank you for your response.

    I've tried the information above and it did help, meaning it did what Jack said it would do. However, I feel that his soloution is a workaround to the problem, and not a complete soloution.  

    For the problem that user cannot see subfoler under Inbox of other mailbox via OWA. Did you open the Inbox folder of other mailbox by clicking option "Open Other User's Inbox..."? If yes, it's normal behavior.

    I'm questioning the normal behavior of not showing the subfolders when opened this way.  Are there any reason why you can't see the subfolders when the other users mailbox is accessed this way?

    Thanks,

    Stian

    • Not Ranked
    • Post Points: 0
  • Do you think 'Open Other User's Inbox.' and 'Open Other Mailbox' are same?

    'Open other users's Inbox' means the folder permission level. And  'Open Other Mailbox'  means you have full access of a mailbox.

    And, you can open new discussion. I believe all users prefer to know how can I do it nor Why. Just like you drive a car, do you always care why the car works in that way?

    • Top 200 Contributor
    • Post Points: 0
  • From Mars , thats the worst reply I have ever seen,. It is bad behavior the OWA does this. Horrible behavior and if thats the final word on how it works then it shoudl be called broken.

    • Not Ranked
    • Post Points: 0
Page 1 of 1 (10 items)