No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Not receiving email that others have sent to me from a specific domain

This question has suggested answer(s) This question has suggested answer(s)

I have recently found out that I am not receiving email since signing up with Office 365 from at least one specific domain. I have looked online and tried the option of looking at Delivery Reports, but nothing. The people are getting emails from me fine, but when they reply or send me a new email it never arrives. Nor do they get any indication that it hasn't been received by me.  Prior to using Office 365 I had no trouble with these emails. I need to get this resolved as soon as possible as it involves a domain which includes several individuals with whom I communicate on a regular basis.  Thoughts? 

All Replies
  • Received the following error when I tried looking at Delivery reports:

    Server CH1PRD0610CA010.namprd06.prod.outlook.com encountered an error while retrieving tracking information from sn2prd0610.outlook.com/.../Exchange.asmx.

  • Hi Riverdale,

    I understand that you can't receive the email from one specific domain, but can you receive yours. Based on my experience, it could be the problem with server connectivity.

    1, If you are using Office plan E, you can use FOPE to trace the server session from that specific domain.
    2, If possible you can post the full NDR report here .

    Additional information , you can also take a look at community.office365.com/.../inbound-mail-flow.aspx

    Thanks, Neo Zhu

  • Hi Riverdale,

    How are you doing? I am just writing to see if there is any progress on this issue. I do not mean to push you. I just want to ensure that you do not encounter any problems during the troubleshooting. Thank you.

    Neo Zhu

  • I haven’t had any luck with trouble shooting yet. it continues to give me the error as noted above when I look for Delivery Reports. I am still having the difficulty, but since I have no indication of not receiving some email it is hard to tell what others I may be missing. I am hoping to try to get in touch with the school board to look at anything on their end but that may be hard to get in touch with the right person.  I am currently on Plan P rather than E, but if this can't get addressed I may need to shift that somehow.

  • It appears that the emails are still being delivered to my old email provider. I have changed the MX entry with them when I set up Office 365 and most are coming through, but apparently some are not, namely ones from the domain in question.

  • Hi Riverdale,

    Can you post your domain information here for further troubleshooting? Based on the description, there is something wrong about the DNS record.

    Thanks, Neo Zhu

  • My domain is kimoconnor.ca and the domain that I seem to  be having trouble with is @avrsb.ca.  There was a hotmail message that seemed to stop at the old provider as well. From what I can tell all other messages are coming through fine.

  • The copy of the message that I just added here seemed to get stopped at the old provider as well, which is the first time that happened. Not sure if it is because I was logged in to the webmail or not - doesn't seem likely,  but...

  • Hi Riverdale,

    After checking the domain, the MX record is setup properly.  Can you post here about the NDR report of sending email to @avrsb.ca

    Thanks, Neo zhu

  • I am not sure what you are looking for. As indicated above, the problem is not sending email to that domain. Rather it is that when someone sends email to me from that domain it stops at my previous email provider where the MX entry changes were made rather than continuing on to my exchange email.

    The only error I get when looking at Delivery Reports I referenced above. It is:

    Server CH1PRD0610CA010.namprd06.prod.outlook.com encountered an error while retrieving tracking information from sn2prd0610.outlook.com/.../Exchange.asmx

  • HI Riverdale,

    For my meaning is if the email can't be delivered to your mailbox from your customer. Our FOPE will get back a NDR report to your customer about the reason of sending failure. On the other hand, we also need to contact with their email server admin to ensure the email has been sent out from their server.

    Thanks, Neo Zhu

  • The people who are sending me email are not receiving any indication that the email is not being received by me. I can get the email only if I log into my old provider. For some reason email from that domain (@avrsb.ca) is not being sent along as per the MX records.  The response that I received from my hosting provider is as follows:

    Hi Kim

    Try to also to whitelist that domain name through microsoft first, If you're still not able to receive email from that domain (avrsb.ca) on to your kimoconnor.ca which happens to be dependent on microsoft email service (given the txt and mx record your set up on your hosting with us for that domain name), you need to follow up with microsoft as the mx record will make all your email service dependent on your other email hosting provider (microsoft).

  • Hello Riverdale,

    Have you tried to add the senders's domain to the "Safe senders" list?

    Office 365 Professional and Small Business customers (P1 Plan) can add safe senders through OWA.

    Instructions for doing this are found at http://help.outlook.com/en-us/140/ms.exch.ecp.junkemailconfiguration.aspx

    In the OWA Options > See all options > Block or Allow page, there are two lists - Safe Senders and Recipients and Blocked Senders.

    Customers may add and remove senders and domains from the lists on this page.

    Please note on the Block or Allow page, the top option is "Don't move e-mail to my Junk E-Mail folder." If this is checked, it turns off all FOPE Spam filtering and all email (except that which contains viruses which are always blocked without exception) is delivered to the Inbox unless it is blocked by the user vis Block/Allow.

    Please let me know if this helps,

    Best regards,

    Arturo Gonzalez

  • I have added the domain to safe senders, but it is still not working. The problem is that the email from that domain is being sent to my email provider (hostpapa) and not being directed to microsoft servers even though all MX records and DNS records appear to be correct (according to provider).  All other email is coming through fine.  I have contacted the tech support dept at the domain in question and they say it is nothing to do with their end. They can also receive my emails fine but not sending them back to me. Because it is being delivered to a mailbox then they receive no errors either.

    Any other suggestions?  This is very frustrating and no one seems to know what is causing the problem.  It is almost enough to make me get rid of the Microsoft Office 365 stuff and go back to the old way as I never had any of these problems. However, there are other components of the service that I really like. I have considered changing to an Enterprise plan but I don't even know if that will solve the problem or just cause more.

  • Hi Riverdale, 

    To troubleshoot the issue, I suggest checking if the domain is configured as shared. You may refer the steps below to check if the domain is a shared domain. If not, please configure the domain as a shared domain. To do this, follow these steps:

    1. Sign in to the Office 365 portal (https://portal.microsoftonline.com/) as a global administrator or a service administrator.
    2. Click Admin, and then under Exchange Online, click Manage.
    3. In the Exchange Control Panel (ECP), click Mail Control, and then click Domains & Protection.
    4. Select the domain that is configured for mail coexistence, and then click Details.
    5. Select Shared, and then click Save.

    For the detailed information, you can refer the article about Users in the on-premises environment are not receiving mail from Office 365 users.
     http://support.microsoft.com/kb/2510049

    Please let me know if this changes anything.

    Best regards,

    Arturo Gonzalez.