Existing certificate prompted after migrated to Office 365...

  • 5 Followers
  • 16 Replies |
  • This post has 0 verified answers |
Answered (Not Verified) This question has suggested answer(s)

Dear Microsoft O365 Support,

 

I have a client which migrated to O365 last week, they were using SBS2008 with the Exchange 2007 that hosted by themselves. I saw that there have a certificate keep prompting from time to time after their Outlook profile mapped the O365 accounts in their Outlook. Please check the attached screen shot as below.

 

Are there any ways to remote the prompting? Please advise. Thanks.

Best Regards,

Steven

 


  • Post Points: 20
All Replies
  • Hi Steven,

    Thanks for posting and screenshot.

    The error message about certificate issue indicates the autodiscover record is incorrect. According to my research, the autodiscover record for your domain does not exist in public DNS. Please make sure there is an CNAME record for autodiscover.yourdomain.com and point to autodiscover.outlook.com available in both internal and public DNS.

    For more information about it, please refer to the two links below:

    Outlook cannot configure a new profile by using Exchange Autodiscover for an Exchange Online mailbox in Office 365

    support.microsoft.com/.../2404385

    Use a CNAME Record to Enable Outlook to Connect

    help.outlook.com/.../cc950655.aspx

    Thanks,
    Anna Guo

    • Top 50 Contributor
    • Post Points: 0
  • Dear Anna,

    Thanks for your reply. I have pointed all of the DNS record directly before migrated to O365. Please check the screenshot as below:

     

      

    And the security alert prompted remote.trends.com.hk certificate which should not be happened in O365 profile. So I am not sure where is the problem. Please advise. Thanks.

     

     Best Regards,

    Steven 

    • Not Ranked
    • Post Points: 0
  • Hi Steven,

    Thanks for your reply.

    Based on the current situation, I would like to clarify the following information to troubleshoot this issue.

    1. Are you using Outlook 2007 to connect to your Office 365 account? Have you installed the latest update for Outlook 2007?

    If not, please install the updates and check this issue.

    2. Could you try to change to another computer which is not in your domain to test this issue? Will this issue persist?

    If this issue still reoccurs, please post the log for Test E-mail Autoconfiguration result for us to check it.

    For how to check it, please refer to the link below:

    1. Click Ctrl and Microsoft Outlook button in the meantime.

    2. Click Test E-mail AutoConfiguration.

    3. Check Use AutoDiscover and uncheck Use Guessmart and Secure Guessmart Authentication and then click Test.

    Please post the whole content of Log here.

    Thanks,
    Anna Guo

    • Top 50 Contributor
    • Post Points: 0
    Suggested by
  • Dear Anna,

     

    Thanks for your reply. All of our clients are using Outlook 2010. The result and log have been captured as below, please check it. Thanks.

     

    Best Regards,

    Steven

     

    • Not Ranked
    • Post Points: 0
  • Hi Steven,

    Thanks for your reply and screen shots.

    Based on the current situation, to troubleshoot the problem that users failed to connect Exchange Online with Outlook client using autodiscover service, please refer to the steps below and check what happens:

    1. Make sure that the Autodiscover CNAME record exists for your email domain and can be queried from internet.

    2. Configure the following registry entries to prevent Outlook client from getting autodiscover information from the service connection point (SCP) in Active Directory.  

       [HKCU\Software\[Policies\]Microsoft\Office\<12.0 or 14.0>\Outlook\AutoDiscover]

       ExcludeScpLookup DWORD 1

       ExcludeHttpsRootDomain DWORD 0

       ExcludeHttpsAutoDiscoverDomain  DWORD 0

       ExcludeHttpRedirect ExcludeSrvRecord DWORD 0

    [Their email domain]  --If exists, delete it.

    3. Run the "Set up and configure your Office desktop apps" by clicking Download in MOP at portal.microsoftonline.com .

    4. Create a new outlook profile by clicking Control Panel -> Mail -> Show Profiles -> "Add".

    5. Follow the article below to configure the Outlook client to connect to Exchange Online.

    Set Up E-Mail in Outlook 2010  help.outlook.com/.../dd253202.aspx

    Please also add a CNAME record for autodiscover.remote.trends.com.hk and point to autodiscover.outlook.com and then see if it helps.

    Thanks,
    Anna Guo

    • Top 50 Contributor
    • Post Points: 0
    Suggested by
  • Dear Anna,

    I cannot find the mentioned registry in either the AD or the workstations. Please check the screenshot as below:

     

      

     

    Best Regards,

    Steven

    • Not Ranked
    • Post Points: 0
  • Hi Steven,

    Thanks for your reply.

    Based on the current situation, I would suggest you try to add a CNAME record for autodiscover.remote.trends.com.hk and point to autodiscover.outlook.com and then see if it helps.

    Thanks,
    Anna Guo

    • Top 50 Contributor
    • Post Points: 0
  • Hi Steven,

    How are things going?

    If you have any other questions or concerns, please do not hesitate to contact us. It is always our pleasure to be of assistance.

    Thanks,
    Anna Guo

    • Top 50 Contributor
    • Post Points: 0
  • Hi Anna,

     

    User reported to me that the problem is persisted after almost 24 hours I added the DNS record, however it improved, it only pop up once when the outlook started, it was pop up many times when the outlook is running. But is that alert must pop up once the Outlook started? Or are there any ways to make the pop up disable?

     

    Best Regards,

    Steven

    • Not Ranked
    • Post Points: 0
  • Hi Steven,

    I glad to know we got improvement. Based on current situation, I would like to clarify if you checked the check box to save username and password? Thanks.

    Best regards,

    Alex Du

    • Top 75 Contributor
    • Post Points: 0
  • Hi Alex,

     

    As you see the first post of mine, you can see there have a security alert keep prompting before, not the username and password prompt. User reported to me that if he pressed "yes", the whole profile will not be usable. So he must keep informing user to press "no" to the security alert.

     

    Best Regards,

    Steven

    • Not Ranked
    • Post Points: 0
  • Hello Steven,

    Is this issue still occuring when trying to get mail through remote.trends.com.hk? If so, you may want to add this CNAME record to your domain registrar: autodiscover.remote.trends.com.hk and point it to autodiscover.outlook.com

    I hope this helps.

    Thank you,
    Ken Berg
    O365 Support
    • Top 500 Contributor
    • Post Points: 0
  • Hi Kenneth,

    The problem still occurring even the CNAME record pointed as you suggested. Please advise. Thanks.

    Best Regards,

    Steven

    • Not Ranked
    • Post Points: 0
  • Dear O365 Support team,

    Anyone one can reply me about this case? Our client said once they press "Yes" for the certificate alert, the whole Outlook profile will need to reconfigure again. Are there any ways to disable that security alert? Please advise.

    Best Regards,

    Steven

    • Not Ranked
    • Post Points: 0
Page 1 of 2 (17 items) 1|2|