Outlook Web App "still working on it"

This question has suggested answer(s) This question has suggested answer(s)

I've been attempting to open my email all morning via the web app.  I have attempted different browsers on both Mac and Windows computers but it always gets stuck at "still working on it."  I am successfully able to log into my OneDrive.  Running Office 365 for Small Business.

All Replies
  • Emily:

    Please go to https://exrca.com and run an "Outlook Connectivity" test in the Office 365 Tab. This can be one way of checking if there are any problems with your server. Use the Autodiscover feature when performing the test.

    Do not post any of the results in here as it will contain some sensitive information. We just want to check if it passes (it will pass with warnings) or if it fails.

    Andres

  • Test passed with warnings.

    1 out of 1 people found this post helpful.

  • Typically, if you get an issue like this, especially with anything Web related (OWA, SharePoint, etc) Microsoft will likely need to get involved. Especially if you have reproduced with multiple browsers. The only other thing to check is if you can reproduce this with your account on another computer or if other user's are experiencing the same results.

    Also, please check your Service health Dashboard to see if there are any alerts that might be affecting Exchange Online at this time.

    0 out of 1 people found this post helpful.

  • This also is currently happening to me.  I cannot log onto my phone nor online.  Please help.

  • Some of my users are also experiencing this issue.  Is this related to the issue reported on the Service Health dashboard today?

  • I'm having the same issue.

  • Hi All,

    Thank you for your reporting.

    I understand that you are still having trouble in accessing emails via Office 365 OWA. This issue has been posted to the Service Health Dashboard (SHD) by now. If you are an Office 365 tenant administrator, you can see the current information and updates on your SHD. If you are experiencing an issue and do not see any related information on your SHD, please let us know since this may be caused by other factors. Sorry for the inconvenience this issue is causing. Your patience and cooperation are highly appreciated!

    Best Regards,
    Edward Qu

    0 out of 1 people found this post helpful.

  • Hi,

    We are also having this issue, multiple accounts tested on multiple browsers.  The SHD on my account for the last couple of days only seems to be showing an issue with printing from OWA and not actually opening the OWA - have I missed something?

    Thanks

  • Hi

    We are also having the same issue for one of our users but we do not see anything on our service health relating to this issue.

    Regards

  • As usual, nothing on the SHD about this. And I've checked several tenants.

    @Edward, can you post the info in this thread?

  • Hi,

    Microsoft - Please get this issue fixed. We all do not have time for this. The OWA is still hanging and will not open. You keep changing the SHD with info, but the SHD is not solving the problem for us all. The problem has not been corrected as you posted on the SHD yesterday.

    Thanks,

    Matt

  • I can confirm a user within one of our tenants is experiencing the same issue that's been reported here. As others have said, there is no mention of the OWA "still working on it" loop in the SHD. Are Microsoft working on a fix for this?

  • Any update on this, it is happening to one of our senior management who urgently needs access

  • My email magically started working again.  Not sure what fixed it.

  • My email magically started working again also.  Not sure what fixed it. Will keep you posted if I still have any issues.