No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Calendar Sharing and permissions

This question is answered This question is answered

I am the administrator of our 365.  Right now I am working on sharing my calendar with everyone in our exchange group.  I am having problems with the second person I shared with.  All the permissions are the same as the 1st person and the 3rd, but the calendar is showing all the appointments as busy on the 2nd.  He is able to add and delete appointments, but any appointment entered by myself or the other 2 so far, shows busy. 

1st is using Outlook 2007 on XP

2nd is using Outlook 2010 on Windows 7 professional

3rd is using Outlook 2007 on Windows 7 professional

I am using Outlook 2010 on Windows 7 professional

I have all the permissions set at Publishing Editor, Full details, Edit all, Delete all, Folder visible.

 

How do I troubleshoot or correct the 2nd user to see the full appointments?

Verified Answer
  • Hi 30Seconds,

    Before moving on, would you please confirm the following information?
    My understanding of your situation is that, you have shared your calendar with three users. However, only two users can view the detailed information in the shared calendar. One user can only view the free/busy information from the calendar. Is it right?
    Besides, when you say “he able to add and delete appointments”, are you referring those appointments are your shared calendar or appointments?

    Based on my experience, if only sharing free/busy information, and not including subject and location when configure sharing calendar with other users, users will only have free/busy information. In this situation, could you please re-send share calendar invitation to this user and choose the option “Full details”, to see if he/she can see detailed information in the calendar?

    Thanks,
    Grace Shi

  • Hi 30Seconds,

    Thanks for your post. I'm glad to hear that it works on OWA.  By doing this, we can confirm that the user Exchange Online account and your Office365 is work as expected.

    You are right. Once we share our calendar by using OWA, there is only three options we can used : Default , Limited detail and owner.The detail information about the calendar permission, you can check the picture below :

    As for this case, I would suggest you can use Powershell for the further permission setup. Sharing the calendar via Powershell (connect Exchange Online via Powershell)  Add-MailboxFolderPermission -Identity share-mailbox-01:\calendar -user userid -AccessRights owner

    Thanks,
    Neo Zhu

All Replies
  • Hi 30Seconds,

    Before moving on, would you please confirm the following information?
    My understanding of your situation is that, you have shared your calendar with three users. However, only two users can view the detailed information in the shared calendar. One user can only view the free/busy information from the calendar. Is it right?
    Besides, when you say “he able to add and delete appointments”, are you referring those appointments are your shared calendar or appointments?

    Based on my experience, if only sharing free/busy information, and not including subject and location when configure sharing calendar with other users, users will only have free/busy information. In this situation, could you please re-send share calendar invitation to this user and choose the option “Full details”, to see if he/she can see detailed information in the calendar?

    Thanks,
    Grace Shi

  • Hi,

    How is everything going? Do you have any updates about the status of the issue?

    Thanks,

    Neo Zhu

  • Hi Grace and Neo,

    I am still having a problem with the 2nd user viewing the calendar as free/busy.  This morning I unshared and deleted the calendar then redid the sharing.  All looked good and permissions were set for Publishing Editor.  Still showing on his end as free/busy.  Last week I had followed Grace's advice and re-sent the sharing.  That didn't do anything different that I could see.

  • Hi,

    Thanks for your reply. I just want to ensure that if it's the same by using Outlook Web Apps (http://mail.office365.com). If still have problem on OWA, I'd like you can re-setup it on OWA . Detail inforamtion ,you can check help.outlook.com/.../ms.exch.owap.sharing.aspx

    Thanks,

    Neo Zhu

  • Hello Neo,

    I shared the calendar using OWA and it worked to a point.  The user is now able to see the actual appointments instead of only free/busy, but he can't edit any appointments and only email a meeting request.  So I set permissions through the OWA to Publishing Editor as I have in my Outlook without any changes.  I viewed the video link you sent with directions on how to share on OWA, I did precisely those directions.  However, I do need to note that when I set to share a calendar with any of the user's, I only have the option to choose 'Availiablity only' in Outlook or 'Free/Busy' in OWA.

  • Hi 30Seconds,

    Thanks for your post. I'm glad to hear that it works on OWA.  By doing this, we can confirm that the user Exchange Online account and your Office365 is work as expected.

    You are right. Once we share our calendar by using OWA, there is only three options we can used : Default , Limited detail and owner.The detail information about the calendar permission, you can check the picture below :

    As for this case, I would suggest you can use Powershell for the further permission setup. Sharing the calendar via Powershell (connect Exchange Online via Powershell)  Add-MailboxFolderPermission -Identity share-mailbox-01:\calendar -user userid -AccessRights owner

    Thanks,
    Neo Zhu

  • Hi 30Seconds,

    How is everything going? Do you have any updates about the status of the issue?

    Thanks,
    Neo Zhu

  • I tried to install PowerShell and it was denied.  The execution of scripts is disabled on my system.  Then I tried to enable by following the directions using the command " set-executionpolicy remotesigned ".  This was also denied.  

  • Hi 30Seconds,

    Thanks for your information. Based on the description, I would you can run the PowerShell as administrator permission "runas administrator". If still not working, please capture a screenshot about the error message and post them here.

    Thanks,

    Neo Zhu

  • Hi 30Seconds,

    How are you?  I just want to ensure that you didn't encounter any problem during the troubleshooting. If you have any thing need help, please feel free to post them here.

    Thanks,
    Neo Zhu