No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Problem connecting Samsung Galaxy S2 phone

  • 6 Followers
  • 6 Replies |
  • This post has 1 verified answer |
Answered (Verified) This question is answered

Hi

 

I have just migrated a customer to Office 365.

I have set up their HTC's and iPhones without any problems and I also set up a single SGS2.

But it did not sync, so I removed the account and now I'm unable to set it up again.

I have tried every combination of servers, usernames with and without domain etc, but now I'm out of good ideas.

 

Does anyone have a suggetion to what I might try to make it work?

 

Btw if I do a autodiscovery test with Outlook 2010 everything works fine.

  • Post Points: 20
Verified Answer
  • Hi Jensskov,

    First of all, thanks for Zac’s suggestions on this point.
    For troubleshooting this sync issue, would you please try this steps below to see if any improvement on the status?
    1. Follow this latest wizard to set up your Exchange Online account on your Samsung device

    In some cases, Android mobile devices may experience connection problems using m.outlook.com as the server name. If you are having problems connecting, go to the Host name line on the About page. Use the value shown under Host name for the Exchange ActiveSync server name for your device.

    2. If the step 1 couldn’t address this issue, please use the URL of OWA without /owa as your server address and try again.
    For example, if the URL of OWA is https://ch1prd0404.outlook.com/owa, you may use ch1prd0404.outlook.com for a try.

    In addition, setting up POP or IMAP E-mail on android mobile device is supported in Office 365. You may refer to the article below and set it up on your side.
    http://help.outlook.com/en-us/140/dd772208.aspx?selfhelp

    Thanks,
    Grace Shi

    • Top 50 Contributor
    • Post Points: 0
All Replies
  • If you had tried this last week it would have worked. But starting Saturday afternoon, my Samsung Galaxy S2 will no longer connect to my Exchange mailbox at Microsoft Office 365. After extensive troubleshooting I learned from another Galaxy owner that there is a bug in the ActiveSync implementation included in the Android build used by Samsung. Under certain conditions the Samsung Galaxy S2 will not connect to an Exchange mailbox, and it seems that Microsoft Office 365 meets those conditions. So while owners of the Galaxy S2 may be able to connect to other Exchange servers, they will not be able to connect to a mailbox at Office 365.

    The options for working around this include:

    - Buying a new phone without the non-compliant implementation of ActiveSync

    - Buying a third-party Exchange client such as Moxier Mail or Touchdown

    - Switching to an Exchange host that does not trigger the bug on the Galaxy

    - Maybe IMAP is supported by Office 365?

    Here is the link to my Get Satisfaction page on this issue:

    getsatisfaction.com/.../samsung_galaxy_s2_incompatible_with_microsoft_office_365_hosted_exchange

    • Not Ranked
    • Post Points: 0
  • Well there seems to be another possible resolution to this issue. That is to manually configure the account, use the host name from the About page, then after configuring pull down from the top to approve the hidden security message. Hope this helps, I am delighted to have found a possible workaround.

    • Not Ranked
    • Post Points: 0
  • Hi Jensskov,

    First of all, thanks for Zac’s suggestions on this point.
    For troubleshooting this sync issue, would you please try this steps below to see if any improvement on the status?
    1. Follow this latest wizard to set up your Exchange Online account on your Samsung device

    In some cases, Android mobile devices may experience connection problems using m.outlook.com as the server name. If you are having problems connecting, go to the Host name line on the About page. Use the value shown under Host name for the Exchange ActiveSync server name for your device.

    2. If the step 1 couldn’t address this issue, please use the URL of OWA without /owa as your server address and try again.
    For example, if the URL of OWA is https://ch1prd0404.outlook.com/owa, you may use ch1prd0404.outlook.com for a try.

    In addition, setting up POP or IMAP E-mail on android mobile device is supported in Office 365. You may refer to the article below and set it up on your side.
    http://help.outlook.com/en-us/140/dd772208.aspx?selfhelp

    Thanks,
    Grace Shi

    • Top 50 Contributor
    • Post Points: 0
  • Hi Jensskov,

    How is the thing going? Has the mobile phone been able to connect to Office 365?

    Thanks,
    Lester Zhang

    • Top 50 Contributor
    • Post Points: 0
  • Mine worked a few weeks ago while testing, then when I went for it for real it did not, but have now tried the above

    2. If the step 1 couldn’t address this issue, please use the URL of OWA without /owa as your server address and try again.

    For example, if the URL of OWA is ch1prd0404.outlook.com/owa, you may use ch1prd0404.outlook.com for a try.

    in my case amsprd0304.outlook.com for the server address and yes it worked.

    Yippeeeee took me all weekend to find this though.

    • Not Ranked
    • Post Points: 0
    Suggested by
  • Hello Malvarlin,

    Thank you for sharing your experience. I am glad the problem is fixed with Grace’s suggestion. If you have any additional questions when using Office 365 in the future, please feel free to post new question in the forum. Thank you.

    Jack Sun

    • Top 50 Contributor
    • Post Points: 0
Page 1 of 1 (7 items)