Public Folders default email address

This question has suggested answer(s) This question has suggested answer(s)

Hi

 we just created a public folder in Office 365. This folder will receive emails for a group.

Once created and mail enabled it took the default (@mydomain.onmicrosoft) email address. I addedd the correct one and it was added with no problems.

The real problem is that I canno change the "replay" email address, the one that is used when sending emails (Send As) as this folder. The configuration states:

------

Each email address type has one default reply address. The default reply address is displayed in bold. To change the default reply address, select the email address that you want to set as the default, and then double-click to edit it.

------

But the "Make this the reply address" is NOT present in any of the addresses, even the BOLD one.

Modifying the default one results in the @onmicrosft address being regenerated after one minute.

How can I modify the Reply/Default email address of a public folder? The documentation is flawed.

I need this to go into production!

Thanks

All Replies
  • Hi ICT SF,

    I'd like to confirm if you are using Office 365 Enterprise. If so, please try the following steps to modify the default email address of a public folder:
    1. Login to Office 365 with an administrator account.
    2. Click "Exchange".

    3. Go to "public folders", and then click "public folders".
    4. Select a public folder, and then click "edit".
    5. Navigate to "email address", and click "edit".

     

    Thanks,
    Edward Qu

  • Hi ICTSF,

    How are things going?

    Thanks,
    Aaron Yuan

  • This is exchactly what I did.

    The problem is that you stopped one step before an useful answer: when I click the "pencil/edit" button I have the ability to ADD new addresses, but I cannot modify the default one, for two reasons:

    1) There is no checkbox to make an address the default (bold) one, as stated in the text you can read in your bitmap

    2) If I edit the default bold address, it is reverted to the "onmicrosoft" address automatically.

    This is the same thing I wrote in the first post.

    You simply copy&pasted two screenshots, but you need to try to do what you're saying to verify the results.

    I switched to using shared mailboxes, but they have problems too: I give "Full access" to 5 users, but If I re-open the permissions page only one is present. I must add users one at time, waiting some minutes in between.

    This is true for the "Full access" permission list, where you see full user names. The "Send As" list shows account names instead of full names, and here I can add several users in a single operation with no problems.

    It seems a very very flaky UI...

  • Hi ICTSF,

    I can completely understand. In this situation, I do suggest you submit a feedback via the following link. Your comments and suggestions will help us improve our service.
    http://mymfe.microsoft.com/Microsoft%20%20Online%20%20Services/Feedback.aspx?formID=210  

    Thanks,
    Aaron Yuan

  • To fix this you need to run the following powershell command against the Public folder you would like to change the primary address, once this command has been run a new tick box appears in the Office 365 Exchange web console public folder menu, called set as reply address.

    Set-MailPublicFolder -Identity "\foldername" -EmailAddressPolicyEnabled $False

    Cheers

    4 out of 4 people found this post helpful.

  • Great, that is exactly what I was looking for.

    Thanks

  • Hello,

    Is there a way to modify the default email address Policy in order to make the checkbox "set as reply address" visible by default for all new public folder?

    (and to avoid having to launch the powershell command each time we activate a public folder email feature)

    Thanks

    Best regards

    Pierre

  • Hi,

    Just want top say that I had to change multiple External Email addresses that are in public folders and used a simple copy and paste of the below, changing obviously location of public folder, each one then change and moved to the next.

    Set-MailPublicFolder -Identity "\external\accounts" -EmailAddressPolicyEnabled $False

    Set-MailPublicFolder -Identity "\external\enquiries" -EmailAddressPolicyEnabled $False

    Set-MailPublicFolder -Identity "\external\info" -EmailAddressPolicyEnabled $False

    Set-MailPublicFolder -Identity "\external\jobs" -EmailAddressPolicyEnabled $False

    Set-MailPublicFolder -Identity "\external\junk" -EmailAddressPolicyEnabled $False

    Set-MailPublicFolder -Identity "\external\public" -EmailAddressPolicyEnabled $False

    Set-MailPublicFolder -Identity "\external\sales" -EmailAddressPolicyEnabled $False

    Set-MailPublicFolder -Identity "\external\support" -EmailAddressPolicyEnabled $False

    As for the option "set as reply address" I have not yet been able to find a powershell command that will set this as a default.  I was speaking to a Microsoft Rep earlier and he suggested it could be a GUI error and will get back to me.

    I don't have this issue with shared folders as the option is available, so suggests it is something that can be implemented to public folders.  Whether or not it happens is down to the powers above,

  • Thanks a lot for this! Was tearing my hair out trying to get this sorted out