No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

ISSUE: Unable to resolve 2013 cloud mailbox name in 2010 outlook desktop client

This question has suggested answer(s) This question has suggested answer(s)


We are experiencing this problem since past one week, and I am trying to troubleshoot this issue. 


We have 2013 Office 365 Preview EXO accounts to access via OWA 2013. some users in the cloud (onmicrosoft.com) are accessing the 2013 accounts via desktop client- 2010 Outlook

ISSUE: Why is the 2010 client unable to automatically configure 2013 account settings? OR in case if the 2013 account gets mapped, upon starting Outlook, outlook profile setup continuously prompts for authentication against Exchange server and dose not resolve the name.

However 2010 client is able to map the 2013 accounts in only a couple of laptops/ desktops, but unable to map in majority of desktop/ laptops at our work place. Now we are at a point and not able to move any further, we investigated, researched online, read thru the Microsoft blogs, and the only thing we could come up with is -

In the case where 2010 Outlook client is automatically able to configure 2013 account settings, the Autodiscover sets the network security to Anonymous Authentication where as in the other setup it sets it to Basic Authentication, and Outlook client dose not even give us an option of Anonymous Authentication (at least to make a change once the profile is mapped). It is the Outlook client that's deciding whether or not to setup the outlook profile with Anonymous Authentication, if it is not doing so we are not able to access the 2013 account via 2010 client.

Below is the snapshot for a mapped 2013 cloud mailbox. and we wouldnt see the option Anonymous Authentication as below when a profile is mapped, but the outlook is unable to resolve the Name.


What should i do to map these 2013 EXO accounts to 2010 desktop Outlook Client?


Any help/guidance you can give will be greatly appreciated.



All Replies
  • Hi Thummalacheruvu,

    I suggest you update the CNAME record in your domain DNS hosting provider.

    After that, you can try to set up email in Outlook 2010.

    In addition, here is the a link for your reference:

    support.microsoft.com/.../2404385

    Thanks,

    Cherry Wang

  • Hey Cherry,

    We are using the native onmicrosoft.com domain. Here is our sample Email ID for reference pavan@[Tennat domain was removed by Moderator].onmicrosoft.com

    Since onmicrosoft.com domain is owned by Microsoft, we do not have the control on the CNAME record config

    What should be my next steps?

    I appreciate your help and thank you for it.

  • Hi Thummalacheruvu,

    I suggest you create a new profile for Outlook, and reconfigure your Office 365 account.

    For your reference:

    How to create and configure email profiles in Outlook

    Thanks,

    Cherry Wang

  • Hi Thummalacheruvu,

    I'm writing to follow up on the previous thread. How are things going?

    Thanks,

    Cherry Wang

  • Hey Cherry,

    As suggested, I created a new profile for outlook 2010, tried mapping the EXO 2013 account, once the configuration is done at this point Outlook prompts to restart. Upon restarting the outlook, for the first time it asks for user credentials. However, this prompting repeats for the password and i am not able to get into the account successfully.


    Also i have tried the following

    Attempt 1 : Uninstalling the 2010 outlook completely,  re install the Outlook again, and tried mapping the account EXO 2013. Attempt unsuccessful.

    Attempt 2 : Total MS Office 2010 pack installed, and tried mapping the EXO 2013 account. Attempt unsuccessful.

    Attempt 3 : Repeated the above attempts in 5 different laptops/PCs.


    What shall i do?


    I appreciate your help and thank you for it. 

  • Hi Thummalacheruvu,

    According to the description, I would like you to review the Service Health Dashboard for any available updates.

    Meanwhile, as a workaround, the following steps are your reference:

    1. Use Add/Remove Programs in Control Panel to remove the MSI installation of the KB 2768349 patch:

    Open Control Panel->Click on Programs and Features->Click on View installed updates->Select Microsoft Office update KB2768349->Choose Uninstall.

    2. For the Click-to-Run (C2R) installation, you will be able to click on Detect and Repair will restore back to prior image:

    Open the Control Panel->Click on Programs and Features->Select Microsoft Office->Click on Change->Select the Online Repair radio button and click Repair.

    If there are any concerns, you can post to the end of the following thread:

    community.office365.com/.../420911.aspx

    Thanks,

    Cherry Wang

  • Hi Cherry,


    I have looked for any available updates on Service Health Dashboard. The Service Health Dashboard looks perfect. No issues, and the planned maintenance says No planned maintenance scheduled.


    Along workaround, i do not have Microsoft Office update KB2768349 in the installed updates for the laptop that has Microsoft Office


    I am still at the same point where i started of 

    1. Unable to resolve 2013 cloud mailbox name in 2010 outlook desktop client
    2. In case the 2013 cloud mailbox account gets mapped in the 2010 desktop client, once the configuration is done, Outlook prompts to restart. Upon restarting the outlook, for the first time it asks for user credentials. However, this prompting repeats for the password and i am not able to get into the account successfully.

    User wants to use the 2010 desktop client as interface for the 2013 cloud mailbox account. 


    Any solution for this?


    I appreciate your help and thank you for it.


    Best Regards,

    V Thummalacheruvu

  • Hi V Thummalacheruvu,

    Based on the updates, I suggest you set up your current Office desktop applications to work with Office 365.

    Here are the steps to do this:

    1. Sign in to Office 365 with your user ID.

    2. In the upper-right corner, click the gear->Office 365 Settings-> software->desktop setup.

    3. On the desktop setup page, click set up.

    A dialog box appears, asking if you want to run the application; click Run, and then follow the instructions.

    During the setup process you’ll sign in again with your Office 365 user ID. Office 365 desktop setup then checks your system configuration and you’ll get options for configuring your desktop applications. You can also learn more about the updates that the desktop setup installs.

    After you select your desktop applications, click Continue to complete the setup process.

    For more information, you can refer to this article:

    Use my current Office desktop apps with Office 365

    Thanks,

    Cherry Wang

  • Cherry,

    Thank you for the prompt response. i have done the recommended setup process, then tried to open outlook again to check if there is any improvement, but the issue still continues to exist :(

    Any other options for further troubleshooting?

    I appreciate your help and thank you for it.

    Thanks,

    V Thummalacheruvu

  • Hi V Thummalacheruvu,

    I'd like to share my test with my Office 365 Preview account setting up in Outlook 2010:

    1. Run Office desktop setup.

    2. Create a new email profile in Outlook 2010.

    3. Configure my account in Outlook 2010.

    4. Restart Outlook 2010, and type the password.

    5. When it appears again, select Remember my credentials.

    I suggest you delete the email account in Outlook 2010, and then refer to the steps above.

    Meanwhile, if there are any SharePoint Online libraries or lists which are connected to Outlook 2010, the issue also can occur. You can first remove them from Outlook 2010, and check to see if the issue persists.

    Thanks,

    Cherry Wang

  • Hi Cherry,

    I have done recommended steps, but there is no improvement. The issue still continues to exist. Outlook keeps popping up password prompt. Also, there are no SharePoint libraries or lists connected to Outlook 2010. I need real solution for this. I am not able to explain what this disruption means to my client.

    People generally want to work with normal desktop apps, not within browser. At least while they are using their own computers with the Office apps installed. Using Office Web Apps instead of the Office rich client does not address my clients issue.

    Is there a solution for this? Will i get a solution if i contact Microsoft Online Services Support?

    For additional troubleshooting, i have used MOSDAL Support Toolkit to collect data. FYI below is the result

    Testing RPC/HTTP connectivity.

    The RPC/HTTP test failed.

    Attempting to ping RPC endpoint 6001 (Exchange Information Store) on server fb3d35f7-4737-48ab-ba5e-65438772b414@[Tenant domain was removed by Moderator].onmicrosoft.com.

    The attempt to ping the endpoint failed.

    Additional Details

    An RPC error was thrown by the RPC Runtime process. Error 1818 1818

    WHat shall i do?

    I appreciate your help and thank you for it.

    Best Rergards,

    V Thummalacheruvu

  • Hello V,

    My recommendation are

    1. Make sure you have update Outlook 2010 version to latest update.

    support.microsoft.com/.../2625547

    2. For password pop up issue please follow this guide to troubleshooting:

    support.microsoft.com/.../290684

    Thank you.

    Suprapat.

  • Hi V,

    Please kindly let me know the update for this issue.

    Thank you.

    Suprapat.

  • Hi Suprapat,

    Thank you for following up on the issue. While troubleshooting we found there were good # of windows updates that were pending/ not installed. I went over the process of downloading  the important Window updates, reattempted to configure Outlook 2010 once the updates were complete, and it was successful. The issue is resolved :)

    I appreciate your help and thank you for it.

  • Hi V,

    Thank you for the update and I am glad to hear the issue is resolved now.

    Regards,

    Suprapat.