No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Exception Has Been Thrown By Target of an Invocation

  • 10 Followers
  • 19 Replies |
  • This post has 2 verified answers |
Answered (Verified) This question is answered

We have worked through the Exdeploy tool but are still unable to move Mailboxes to the Cloud based organization via the "New Remote Move Request" wizard

 

(I use my domain admin credentials to complete the wizard)

 

Getting very little info in the error, just after around 45 seconds "Error:exception has been thrown by the target of an invocation"

 

New remote move Summary reads (sanitized)

 

RemoteHostName:'mailserver.domain.local'

RemoteCredential:  'System.Management.Automation.PSCredential'

TargetDeliveryDomain:'domain.com'

 

Error received

Summary: 1 item(s). 0 succeeded, 1 failed.
Elapsed time: 00:02:07

 

Error received

Test User 3
Failed

Error:
Exception has been thrown by the target of an invocation.

Exchange Management Shell command attempted:
'9f04302e-fa92-4915-b6f9-5549c2f7d8b9' | New-MoveRequest -Remote -RemoteHostName'mailserver.domain.local'-RemoteCredential 'System.Management.Automation.PSCredential' -TargetDeliveryDomain 'domain.com'

Elapsed Time: 00:00:42

 

We have cehcked the IIS logs and are not getting error 405's, which have been mentioned elsewhere

 

 

  • Post Points: 20
Verified Answer
  • Hello Alisdar,

    One of the actions you can take is to run the move cmdlet from EMS with the -verbose switch. The error you are getting is very generic and sometimes we can get better information from the EMS.

    Some things to check

    is the MRS proxy set to true in the Web.Config file?

    is the user you are moving licensed? (not required but does help a lot of the time)

    is the Office desktop App installed?

    do you have the proper service domain set as the target elivery domain?

    do you see the EWS/MRSPROXY.SVC even show in the IIS log file?

    -Timothy Heeney (MSFT)

    • Top 500 Contributor
    • Post Points: 0
  • Hi Alisdar,

    Besides the part that Timothy suggested, you may also check the following parts.

    RemoteHostName/FQDN part in the 2nd step of the remote move request wizard. It should be the external name of hybrid server and it should be internet resolvable, so it would probably not end with .local, also it should be listed on the certificate of hybrid server.

    Target delivery domain, which is chose in 3rd step of remote move request wizard. Typically, it would be like service.domain.com, and when you click browse to choose, the Target Delivery Domain would show true for service.domain.com .

    Thanks,
    Lester Zhang

    • Top 50 Contributor
    • Post Points: 0
All Replies
  • Hello Alisdar,

    One of the actions you can take is to run the move cmdlet from EMS with the -verbose switch. The error you are getting is very generic and sometimes we can get better information from the EMS.

    Some things to check

    is the MRS proxy set to true in the Web.Config file?

    is the user you are moving licensed? (not required but does help a lot of the time)

    is the Office desktop App installed?

    do you have the proper service domain set as the target elivery domain?

    do you see the EWS/MRSPROXY.SVC even show in the IIS log file?

    -Timothy Heeney (MSFT)

    • Top 500 Contributor
    • Post Points: 0
  • Hi Alisdar,

    Besides the part that Timothy suggested, you may also check the following parts.

    RemoteHostName/FQDN part in the 2nd step of the remote move request wizard. It should be the external name of hybrid server and it should be internet resolvable, so it would probably not end with .local, also it should be listed on the certificate of hybrid server.

    Target delivery domain, which is chose in 3rd step of remote move request wizard. Typically, it would be like service.domain.com, and when you click browse to choose, the Target Delivery Domain would show true for service.domain.com .

    Thanks,
    Lester Zhang

    • Top 50 Contributor
    • Post Points: 0
  • Hi Alisdar,

    How is the thing going? Is there any update of this issue?

    Thanks,
    Lester Zhang

    • Top 50 Contributor
    • Post Points: 0
  • I'm experiancing the same issue..

    is the MRS proxy set to true in the Web.Config file? Yes.. did a test-mrshealt command and all tests are positive.

    is the user you are moving licensed? (not required but does help a lot of the time) My user is licensed

    is the Office desktop App installed? yes

    do you have the proper service domain set as the target elivery domain? Yes

    do you see the EWS/MRSPROXY.SVC even show in the IIS log file? No, there is nog reference to MRSproxy

    • Not Ranked
    • Post Points: 0
  • Hello... do you have TMG in front of the CAS? If so I would turn on logging to see if the requests are being denied. If you are not seeing the requests making it to the CAS it may be the Rule is not setup properly. You need to be sure to not do any preauth on the TMG rule.

    here is a wiki for configuring the TMG rule community.office365.com/.../1042.aspx

    -Timothy Heeney (MSFT)

    • Top 500 Contributor
    • Post Points: 0
  • I'm not using TMG or ISA in front..  My exchange server has an open connection to the internet.

    • Not Ranked
    • Post Points: 0
  • To get a more descriptive error maybe we can run the move through the shell:

    1), Using global administrator account to connect to Exchange Online through PowerShell,help.outlook.com/.../cc546278.aspx

    2), Run $RemoteCredential= Get-Credential and provide the on-premise administrator credential,

    3), Run New-MoveRequest -Identity username -Remote -RemoteHostName externalhybridservername -TargetDeliveryDomain service.contoso.onmicrosoft.com -RemoteCredential $RemoteCredential

    -Timothy Heeney (MSFT)

    • Top 500 Contributor
    • Post Points: 0
  • This is the error I recieve.

    The call to 'mail.domain.com/.../mrsproxy.svc& timed out. Error details: The request channel timed out whil

    e waiting for a reply after 00:00:00. Increase the timeout value passed to the call to Request or increase the SendTime

    out value on the Binding. The time allotted to this operation may have been a portion of a longer timeout. --> The HTTP

    request to 'mail.domain.com/.../mrsproxy.svc& has exceeded the allotted timeout of 00:00:00.0010000. The t

    ime allotted to this operation may have been a portion of a longer timeout. --> The operation has timed out

       + CategoryInfo          : NotSpecified: (0:Int32) [New-MoveRequest], RemoteTransientException

       + FullyQualifiedErrorId : 108F1176,Microsoft.Exchange.Management.RecipientTasks.NewMoveRequest

    • Not Ranked
    • Post Points: 0
  • I'm having the same issue. I thought it was related to WinRM. I was close to completing the configuration but free/busy time would not work in one direction. One user suggested adding WinRM IIS Extension via server manager. Now nothing works.

    Early in the installation I resolved an issue with WinRM via KB 968930 which suggests a special version of WinRM. I installed 968930 and did not install WinRM IIS Extension. Everything worked fine except for the free/busy time issue.

    I'd like to get rid of WinRM IIS Extension and re-install 968930 but now when I run the 968930 install I receive an error stating "This update is not applicable to your computer".

    I'd like to know what's going on with WinRM so I don't have to start from scratch every time something goes wrong.

    • Not Ranked
    • Post Points: 0
  • This one turned out to be a simple fix, although not entirely sure why this fixed it.

    Had to tick the checkbox for "Use the following source forest's credential"  on the "Connection Configurations" screen of the "New Remote Move request" wizard. Entered the credentials of my user account with appropriate priviliges in the environment (in DOMAIN\Username format) and continued through the wizard and all ran OK

    It seems that even if these are the same as the credentials used to log onto the Hybrid server, they need to be re-entered to complete the move request

    • Not Ranked
    • Post Points: 0
    Suggested by
  • This is not used when you use the commandline. I've used the correct line with admin credentials but still the same error..

    • Not Ranked
    • Post Points: 0
  • Entering the credentials makes no difference in my situation. Still cannot move anyone.

    • Not Ranked
    • Post Points: 0
  • Hi MJanssens,

    The error indicates this issue is related to time out period. So you may check following value.

    On the hybrid server, open the following file with a text editor such as Notepad, <Exchange Installation Path>\V14\ClientAccess\ExchWeb\EWS\web.config, locate the following section in the web.config file: <!-- Mailbox Replication Proxy Service configuration -->
    Check the DataImportTimeout and set it to 00:10:00.

     

    For both cases, since the error is very generic, so even the symptom is exact the same, the cause and the troubleshooting steps could be totally different. So I would suggest open a new thread for each case with detailed description. So we can have a clear idea of this issue without mixing it with the original one in this thread.

     

    Thanks,
    Lester Zhang

    • Top 50 Contributor
    • Post Points: 0
  • Hi Lester,

    After some troubleshooting it apears that I had a problem with my ssl certificates. I've solved this by creating a new pair of certificates and now everything works perfect!

    Many thanks!

    Kind regards,

    Michel Janssens

    • Not Ranked
    • Post Points: 0
Page 1 of 2 (20 items) 1|2|