No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Internal Email producing BounceBack:#550 5.1.1 RESOLVER.ADR.ExRecipNotFound; not found ##

This question has suggested answer(s) This question has suggested answer(s)

One of our users has two email addresses.  Primary email and an alias. The alias email address was formerly a distribution group but has since been removed and added as an alias about 3 months ago.


Sending to his email will occasionally produce a bounceback email that the address can not be found. This is usually fixed by removing the AutoCorrect address in Outlook however that doesn't seem to be a permanent fix as we've done that numerous times on the same PC and it still gets bouncebacks a few weeks later.


Is there a more permanent fix?


Here is a portion of the bounce-back email:


Delivery has failed to these recipients or groups:
 
Rich Herrschaft
The e-mail address you entered couldn't be found. Please check the recipient's e-mail address and try to resend the message. If the problem continues, please contact your helpdesk.

 
 
 
 
 
 
 
Diagnostic information for administrators:
 
Generating server: anholt.onmicrosoft.com
 
IMCEAEX-_O=EXCHANGELABS_OU=EXCHANGE+20ADMINISTRATIVE+20GROUP+20+28FYDIBOHF23SPDLT+29_CN=RECIPIENTS_CN=827865984d33455b8a289b007a37f400-Rich+20Herrschaft@namprd08.prod.outlook.com
#550 5.1.1 RESOLVER.ADR.ExRecipNotFound; not found ##
 
Original message headers:

All Replies
  • This is a known issue with Outlook autocomplete and Exchange.  To fix it permanently you will need to add an X500 address to the user as per these articles

    support.microsoft.com/.../555197

    You can find more information in this Forum thread

    community.office365.com/.../70715.aspx

    1 out of 1 people found this post helpful.

  • I think I'm almost there . . .

    Since I never migrated anything from an old server, the person in question had an email address that was a distribution group, then removed and set back up as an alias. I don't have anything to find the old X.500 address except for the bounceback email. Would I run the following commands? (rherrschaft is the username in question)

    1) $user=Get-Mailbox rherrschaft

    2) $user.EmailAddresses+=”X500:/o=EXCHANGELABS/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=827865984d33455b8a289b007a37f400-Rich Herrschaft@namprd08.prod.outlook.com”

    3) Set-Mailbox rherrschaft –EmailAddresses $user.EmailAddresses

    4) Get-Mailbox rherrschaft | FL emailaddresses

  • You can try to use the Cmdlets.

    Then update the result to this thread

  • Mars, can you elaborate on the cmdlets?  I'm not sure what you trying to say.

    Alan, I tried the commands i posted yesterday that I got from your links. Waiting to see if they work or not. It's our CEO who's having a problem sending to "rherrschaft" and I usually only hear from him when things aren't going right. I guess no news is good news!

    I'll update when I know for sure.

    Thanks for the help!

  • Hope it works out.  As I said, I've never done it on Office 365 before but I've done it a million times in other Exchange environments!  Please report back when you know for sure so I can make a note for next time.

  • Still a bounce back. Do you notice anything I'm missing in my script?

  • Hello There,

    Verify and make sure the "LegacyExchangeDN" attribute of the mailbox database is right.

    By Using ADSI Edit tool,

    Expand to ConfigurationàCN=ServicesàCN=Microsoft ExchangeàCN=organization nameàCN=Administrative GroupsàCN=Exchange Administrative Groupà

    CN=Database Availability GroupsàCN=Databases

    Edit all the properties of LegacyExchangeDN.

    If the "LegacyExchangeDN" attribute is still not used when the message is sent to internal recipients. Try this to resolve this issue, download and then install Exchange Server 2010 Service Pack 1 (SP1) from the following Microsoft website: http://www.microsoft.com/downloads/en/details.aspx?FamilyID=50b32685-4356-49cc-8b37-d9c9d4ea3f5b.

    Feel free to update the post with any additional questions or concerns.

    Best regards,

    Roger MSFT Support

  • Thanks for your help but this is an Office 365 setup; it's hosted by microsoft and so we don't have an actual server to install/run these tools on.

  • Hi Sminkey,

    Try these steps below:

    Easy method:

    Start typing the email address you would like to clear from the cache until outlook displays it.
    Press the down arrow key to select the email address
    Press the delete button.

    More involved method: 
       Note: It will allow you to clear all the entries from the address cache. (outlook.nk2)

     Close Outlook and make sure it is not running using the task manager.
    Open Windows Explorer and Paste %APPDATA%\Microsoft\Outlook into the address bar.
    Delete the file Outlook.nk2.

    Outlook 2010 only:
    Go to File, Options, Mail, and then click on the Empty Auto-Complete List button under the Send Messages header.
    If you need further assistance, please free to update the post.

    Best regards,
    Roger MSFT Support

  • Roger, I appreciate the help but in my original post I stated that on several occasions we have removed the Auto Complete entry. It works for a few weeks/months, but eventually the problem returns.

  • Hello Curtis Sminkey,

    I suggest you add the target address, also known as the Service Routing Address, to the mail-enabled user in the on-premises environment. To do this, use one of the following methods.

    Method 1: Exchange Management Console

    1.

    Open the Exchange Management Console, and then locate the user.

    2.

    Right-click the user and then click Properties.

    3.

    Click the Mail Flow Settings tab, click Delivery Options, and then click Properties.

    4.

    In the Forwarding address box, check whether the Service Routing Address is present. If the address is not present, add the correct address based on the service routing domain for your organization. For example, if the service routing domain is service.contoso.com, the Service Routing Address will be alias@service.contoso.com.

    5.

    Click OK.

    Method 2: Active Directory Service Interfaces (ADSI) Editor

    1.

    Click Start, click Run, type adsiedit.msc, and then click OK.

    2.

    Locate and right-click the user, and then click Properties.

    Note To determine the container to which the user belongs; view the user properties in the Exchange Management Console.

    3.

    Click the Attribute Editor tab, and then double-click Target Address.

    4.

    Type the external Simple Mail Transfer Protocol (SMTP) address.

    5.

    Click OK.

    After the service routing domain is configured, confirm that the issues are resolved.


    Best regards,
    Roger

  • Hello MultibaseAdmin,

    I apologize for any inconveniences. To answer your question, the TargetAddress should be updated in your local server. Also, understand that TargetAddress property specifies the delivery address to which recipient e-mails should be sent.

    If you have additional questions or concerns feel free to post on the forum.

    Best regards,
    Roger MSFT Support

  • Hi MultibaseAdmin,

    How are things going? Did we answer your question to your satisfaction?

    If you have any other questions or concerns, please do not hesitate to contact us. It is always our pleasure to be of assistance.

    Regards,

    Samuel