No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

changing permissions on a calendar using powershell

This question is answered This question is answered

Hi All,

 

I have a puzzling issue. On occassion, I need to grant access to certain calendars to a specific group inside my organization. I usually do so by running the following command:

PS C:\Windows\system32> Add-MailboxFolderPermission -Identity firstname.lastname@mycompany.com:\calendar -user team@mycompany.com -AccessRights reviewer

 

team@mycompany.com is a distibution list created by us with the entire team as members and this works perfectly.

 

However, if I remove these permissions and try to re-add permissions for a different distribution list, say hr@mycompany.com , I get the following error:

 

The user "hr@mycompany.com" is either not valid SMTP address, or there is no m
atching information.
    + CategoryInfo          : NotSpecified: (0:Int32) [Add-MailboxFolderPermis
   sion], InvalidExternalUserIdException
    + FullyQualifiedErrorId : 4350690D,Microsoft.Exchange.Management.StoreTask
   s.AddMailboxFolderPermission

 

I have checked that the address is indeed correct, and cannot find any differences, apart from the members, between the two lists, so am puzzled as to why this is occurring. Can anybody shed some light on this please?

 

Thanks a million in advance.

 

All the best,

 

BigMik

 

Verified Answer
  • Hi BigMik,

    Thanks for your post. For setting the permission for a distribution group, you need to enable the distribution group as a security group . For this case, you need to re-create the distribution group and select "Make this group a security group " option when you re-create it.

    Thanks, Neo Zhu

  • Hi BigMik,

    How are you doing? I am just writing to see if there is any progress on this issue. I do not mean to push you. I just want to ensure that you do not encounter any problems during the troubleshooting. Thank you.

    Neo Zhu

All Replies
  • Hi BigMik,

    Thanks for your post. For setting the permission for a distribution group, you need to enable the distribution group as a security group . For this case, you need to re-create the distribution group and select "Make this group a security group " option when you re-create it.

    Thanks, Neo Zhu

  • Hi BigMik,

    How are you doing? I am just writing to see if there is any progress on this issue. I do not mean to push you. I just want to ensure that you do not encounter any problems during the troubleshooting. Thank you.

    Neo Zhu

  • Hi Neo,

    Thanks for your help, it worked a treat.

    All the best.

    BigMik