Out of Office replies not sent

  • 7 Followers
  • 29 Replies |
  • This post has 0 verified answers |
Not Answered This question is not answered

Our client reported that they had set their Out of Office notifications, but the replies did not seem to be sent to either internal, or external senders.


I logged into OWA as that user and checked the details for myself.  I verified that the date range for the replies to be sent was current and that ALL senders, including ALL EXTERNAL senders was enabled.


I then sent two emails to this user - one from my own O365 account (not on the same domain or plan) and another from own personal Hotmail account.  I then checked the users Inbox and saw that both of my emails had been received, however, I did not receive an automatic reply to either email.


I have removed the Out of Office notifications and re-enabled them myself, but the issue persists.


My colleague has also looked over the settings to ensure I have not missed anything obvious.


A screenshot of the Out of Office settings:


  


I have checked my spam filter and Junk folders in Outlook to make sure the auto-reply was not in there.


Can you offer any advice please?

  • Post Points: 35
All Replies
  • please configure an outlook profile for the affected user and then use MFCMAPI to delete the following hidden rules:

    • IPM.Note.Rules.ExternalOofTemplate.Microsoft

    • IPM.Note.Rules.OofTemplate.Microsoft

    • IPM.Rule.Message

    • IPM.Rule.Organizer

    How to delete corrupted and hidden rules from a single mailbox in Outlook 2003

    support.microsoft.com/.../924297

    Best Regards
    Sun Zheng

    Microsoft Office 365 Support

     

     

    • Not Ranked
    • Post Points: 0
  • I've followed the instruction given at support.microsoft.com/.../924297 (Although the user is using Outlook 2007).  Although I can delete all instances of IPM.Note.Rules.ExternalOofTemplate.Microsoft and IPM.Note.Rules.OofTemplate.Microsoft, I cannot seem to be able to delete any instances of IPM.Rule.Message.  When I confirm the delete, I get the following window:



    ...and the instances still remain in the list:



    Can you advise further please?

    • Not Ranked
    • Post Points: 0
  • Hi Chris,

    some of rules IPM.Rule.Message can't be deleted, this is expected, we can safely ignore them. After finishing the removing rules operation, please go to check if the issue persists and let us know the result.

    Best Regards
    Sun Zheng

    Microsoft Office 365 Support

     

     

    • Not Ranked
    • Post Points: 0
  • Hello Chris Lilley,

    Did the answers help you? Let us know if you need further assistance from us.

    Best Regards
    Sun Zheng

    Microsoft Office 365 Support

     

     

    • Not Ranked
    • Post Points: 0
  • No, unfortuantely not.  The user returned to work and the auto-replies were then turned off.  After 1 day I again set the auto-reply using the online portal, again ensuring that external users were to be replied to and sent a test email, I saw my email arrive in the users mailbox, however, I received no auto-reply.

    • Not Ranked
    • Post Points: 0
  • Hello Chris Lilley,

    I'd like to know if the issue occured for all users or just one user?

    Best Regards
    Sun Zheng

    Microsoft Office 365 Support

     

     

    • Not Ranked
    • Post Points: 0
  • Just one user.  There are only two main users on this domain.  The Out of Office notifications work for one user, but not the other.

    • Not Ranked
    • Post Points: 0
  • Hello Chris Lilley,

    since another mailbox works fine, in general, there is no issue on exchange server, the cause should be related to the affected mailbox self. Please try to run below cmdlet in remote powershsell to check the OFF is enabeld on the mailbox and ensure the data confirguration is correct as well:

    Get-Mailbox 'affected mailbox name' | Get-MailboxAutoReplyConfiguration

    in addtion, please also test to check if another mailbox can receive OOF message when trying to send message to the affected mailbox.

    Best Regards
    Sun Zheng

    Microsoft Office 365 Support

     

     

    • Not Ranked
    • Post Points: 0
  • Hello Sun

     

    Using OWA for another user shows the text alert that an autoreply is set when sending an email but on sending the email no autoreply is received.

     

    • Not Ranked
    • Post Points: 0
  • Hello Chris Lilley,

    the retuned information is correct, it indicts OOF is enabled successfully. however, if removing rules from MAPIMFC can't resolve the issue, I think the next step is to rebuild the affected mailbox. you can export all data to PST file firstly, rebuild the mailbox and then import back data from PST.

    Best Regards
    Sun Zheng

    Microsoft Office 365 Support

     

     

    • Not Ranked
    • Post Points: 0
  • When you suggest "Rebuild the mailbox", do you mean remove the user and then re-add them?

    • Not Ranked
    • Post Points: 0
  • yes, you're right, we can backup all data into .PST file and then remove the mailbox -> recreate the mailbox

    Best Regards
    Sun Zheng

    Microsoft Office 365 Support

     

     

    • Not Ranked
    • Post Points: 0
  • OK.  I'll need to plan that with the user, as she works overseas regularly with a laptop, as well as having an office PC, both of which have Outlook configured for her O365 account.

    • Not Ranked
    • Post Points: 0
  • Hello Chris Lilley,

    OK, if there is any update, just drop a note for update.

    Best Regards
    Sun Zheng

    Microsoft Office 365 Support

     

     

    • Not Ranked
    • Post Points: 0
  • Hello


    Well, here's my update.  The user is now on holiday for a few days, so I have been able to backup her mailbox to PST and then remove her account from the Office 365 portal.  I then created a new account for the user and before doing anything else, I tested email to her and using OWA saw that it worked.  Again using OWA I then set the Out of Office auto-replies and sent another email and the auto-reply worked!  All good so far.......

    ...then came the task of re-creating her account in Outlook.  Simple answer - I can't !!  when I run the add account wizard in Outlook 2007, it just continually prompts me for the ID and password.  I know they're correct as I can log into OWA without any issues.

    I have a test PC with Outlook 2010, so I tried using that and got the same result.  It continually prompts me for the ID and password before halting and telling me "An encrypted connection to your mail server is not available":






    I now really am starting to struggle to understand how we can have 5 users on this domain, 4 of them functioning perfectly and this one having so many issues.


    The user will be back from her holiday in a few days and I need to be able to have this new account connected to Outlook, not only for her use, but also so I can import the PST file with the old mail, contacts and calendar items.


    Chris

    • Not Ranked
    • Post Points: 0
  • BREAKTHROUGH!!

    I used Exchange Connectivity Analyser to ascertain that Autodiscover was the issue on this account.  The other 4 accounts were all fine, but one thing I hadn't considered was the fact they were all in the format firstnameonly@domain.co.uk, whereas the troubled account was firstname.surname@domain.co.uk.  I changed the users ID to firstnameonly@domain.co.uk and tested Autodiscover again and it worked!

    I then tried adding the account to Outlook again and this was also successful.  Progress at last.

    • Not Ranked
    • Post Points: 0
  • Are you sure that you turn off OOF before each test pass.

    OOF will only send ONE and only one OOF reply and this cannot be changed.  The only workaround is to turn it off then on again to reset the count.

    This may be why your testing has sporadic results.

    ------+------
    John Gilham
    Agile IT

    Your Agile Technology Partner
    For Your Agile Business

    Connect with us:
    http://www.agileit.com/
    • Top 500 Contributor
    • Post Points: 0
  • Hello John - yes, we had that covered.  We even tried to send from different addresses on different domains which had never sent to this account before and none of them got the auto-reply.

     

    Having read various forums over the last few weeks, it doesnt seem to be an uncommon issue.

     

    So far, removing and re-adding the account seems to have resolved the issue, but I'll post a further update in due course.

    • Not Ranked
    • Post Points: 0
  • Thanks for the update, just wanted to double check.  

    Best of luck!

    ------+------
    John Gilham
    Agile IT

    Your Agile Technology Partner
    For Your Agile Business

    Connect with us:
    http://www.agileit.com/
    • Top 500 Contributor
    • Post Points: 0
  • Back to Square 1 it seems.  I removed the users account from O365 and created a new one as described in my previous post.  I tested the Auto Replies as working and then proceeded to upload the existing mail items (PST) back in.  Now that all of the existing items are in the new account, auto replies no longer work.  We have again tried from accounts that have not sent to this account previously and although the Auto Replies are clearly set with External Contacts enabled, nobody gets the auto-reply from this account..

    There must be something in the existing items contained in the PST that is causing this, but how I go about identifying which item(s) are the culprit is a difficult one.  There are approx. 50,000 items (approx 3GB).

    • Not Ranked
    • Post Points: 0
  • Hi Chris,

    Apologize for not noticing your reply in time. The issue sounds to be related to the PST file content. Have you chosen the "My Contacts only" option when you set the auto reply in your Outlook. If so, auto-reply message will not be sent to the contacts reside in the PST file. You can create a new mailbox for the user, and then copy the email items in the PST file to the mailbox instead of importing it directly. To do this, you can first open the PST as folder in Outlook. Please ensure that you only copy the emails in the PST file.

    Thanks,
    Reken Liu

    • Top 50 Contributor
    • Male
    • Post Points: 0
  • Hi

    No, I set the out of office messages to 'Anyone outside my organization'.  The user was oversea's for the majority of August, so it was important that the auto-replies went to ALL senders.

    Actually, last week, I did exactly as you suggested and backed up all the mailbox items into a PST file and then recreated the user's mailbox again, but instead of importing the items back, the user is going to use them as a local archive and only new items will populate the mailbox now.


    After we did this, we set the auto-replies, tested them and all was good.


    However, this morning, the user has emailed me to say that she thinks the Auto-replies have stopped working again.  I disabled and then re-enabled the auto-replies myself and sent test messages from several external email accounts and none received an auto-reply, so it seems she may be correct.

    At this stage, other than moving this client away from Office 365, I really don't know what to suggest next.

    Chris

    • Not Ranked
    • Post Points: 0
  • Hi Chris,

    It's strange that OOF doesn't work for your mailboxes. I would like to know have you disabled and re-enabled the auto-reply feature in desktop Outlook or the Outlook Web App(OWA)? If you have done it in desktop Outlook, I suggest you repeat this in OWA to see if it works.

    If the issue persists, please run the following PowerShell cmdlet, and provide screenshots about the results here for further troubleshooting:

    Get-MailboxAutoReplyConfiguration yourmailbox

    Thanks,
    Reken Liu

    • Top 50 Contributor
    • Male
    • Post Points: 0
  • The term 'Get-MailboxAutoReplyConfiguration' is not recognized as the name of a
     cmdlet, function, script file, or operable program. Check the spelling of the
    name, or if a path was included, verify that the path is correct and try again.


    I suspect I need a little more information than that one line.  I'll do some reading.

    • Not Ranked
    • Post Points: 0
  • Hi Chris,

    Sorry for not attaching a link for connecting PowerShell to Exchange Online. You need to first connect PowerShell to Exchange Online. If you are using Windows 7 or Windows 2008 OS, please see the instructions in the document below:

    Connect Windows PowerShell to the Service

    Otherwise please first read Install and Configure Windows PowerShell.

    Thanks,
    Reken Liu

    • Top 50 Contributor
    • Male
    • Post Points: 0
  • Just edited my last post, as I realised what I'd done (or not, as the case was) in Powershell.

     

    So......I've re-enabled the Auto-replies again on the users mailbox again, sent a test message to them and waited for 10 mins.  No autoreply.  Check Outlook and OWA and can clearly see the auto-replies are on.

     

    Run the powershell commands and here's the result:

     

     

    • Not Ranked
    • Post Points: 0
  • Hello Chris Lilley,

    Thanks for the post in the forum. I have found a solution from another forum thread I would like you to try.
    The thread is here http://community.office365.com/en-us/forums/158/p/63862/243797.aspx#243797 and the solution was to run the following PowerShell command.


    Set-Mailbox -Identity -DeliverToMailboxAndForward $false -ForwardingSMTPAddress $null

    Can you try this PowerShell command an let me know if it was helpful

    Best Regards

    Samuel

    Samuel A Girod MSFT
    • Top 150 Contributor
    • Post Points: 0
  • I had the same issue too. Auto replies did not work when it was set in Outlook Web App. Then I configured the user's Outlook profile on the Outlook client. I disable the auto reply and re-enable it back from the Outlook client. It then worked. Not sure what is wrong with the Outlook web app. What is the user doesnt have Ms Outlook?

    • Not Ranked
    • Post Points: 0
  • @Chris - Did you get a final resolution for this?

    • Top 150 Contributor
    • Post Points: 0
Page 1 of 2 (30 items) 1|2|