No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Default MRM applied, but Deleted Items not being purged.

  • 4 Followers
  • 8 Replies |
  • This post has 0 verified answers |
Answered (Not Verified) This question has suggested answer(s)

We migrated ~1500 mailboxes from local Exchange 2007 to Office365.  When they came over, they did not have any retention policies applied.  To test the Default MRM, I applied it to my own mailbox.  It has been about week, but I have not seen any of the policies actually working.  I still have items over a year old in my Deleted Items folder.  I was expecting that anything over 30 days old should be purged from this folder, as the Default MRM is configured.

 

Will this policy only actually take effect 30 days after it was applied?  Will it only affect items deleted after the policy was applied to my mailbox?

 

?

  • Post Points: 20
All Replies
  • Hi James,

    To perform rentention opertaion, the Managed Folder Assistant needs to be run against the mailbox. The Managed Folder Assistant has a 7 days (most) interval to operate all mailboxes, so you may see some latency. To trigger the MFA, you need to connect to Exchange Online through PowerShell as administraotr, run Start-ManagedFolderAssistant -Identity username and wait some time to see if any change.

    Thanks,
    Lester Zhang

    • Top 75 Contributor
    • Post Points: 0
    Suggested by
  • I ran the command 6 hours ago, and nothing has changed yet.  I have verified through the Outlook UI and with Powershell, that the "Deleted Items (30 days)" policy has indeed been applied to the Deleted Items folder.

    • Not Ranked
    • Post Points: 0
  • Hi James

    As we known, if the policy were applied then it should take effect. Therefore, would you please help gather the following information at your earlier convenience?

    1. Right click deleted items and capture screenshot on the retention policy tab.
    2. Besides, please check if there were items in deleted items which created time over 30 days. if possible, please help capture screenshot as well.

    Best regards,
    Alex Du

    • Top 75 Contributor
    • Post Points: 0
  • Hi James,

    To deleted items older than 30 days in Deleted items folder, the managed folder assistant needs to run twice, first time, tag the items with operation date and operation action, second time, check the date and perform the defined action. It seems the managed folder assistant does not tag correctly during the first week. Please run the cmdlet one more time and check the status.

    Thanks,
    Lester Zhang

    • Top 75 Contributor
    • Post Points: 0
  • I have run the cmdlet numerous times against numerous mailboxes over numerous days.  No change.  We are using AD Federation, which has made a number of other features not work quite as advertised.  Is Fedaration the problem here, too?

    • Not Ranked
    • Post Points: 0
  • James - Do you have the "Mail Features" available on your Mailbox User Details page...where the Enable Archive option is located?  Because I am having the same issue with the Deleted Items not being purged and the Archive option is not available.  I am trying to determine if these are related.

    Thanks, Justin

    • Not Ranked
    • Post Points: 0
  • For us, the archive option is there, but currently disabled.  This should not affect the retention policy for the Deleted Items though.  I don't want to turn this on, even to test, because the default MRM contains a policy to archive items older than 2 years.  That policy only works when archiving is turned on within Mail Features, and we absolutely do not want any our mailboxes moving data into an archive.

    • Not Ranked
    • Post Points: 0
  • I've opened up a ticket, now.  Still no resolution.  The VP of my division wants to knw why his Deleted Items are not being purged like he asked.

     

    • Not Ranked
    • Post Points: 0
Page 1 of 1 (9 items)