No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Online Archive / Archive Mailbox Not Available

This question is not answered This question is not answered

Hello,

   I have two Office 365 P1 accounts (different domains) one created May 2011 and the other Feb 2012.  I was able to configure the Online Archive / Archive Mailbox in the account created in May 2011 using PowerShell however I am not able to configure it on the Feb 2012 account.  I have followed the instructions on "Enable an Archive Mailbox http://help.outlook.com/en-us/140/ms.exch.ecp.enablearchivemailbox.aspx" however it does not work.

1) Mailbox Features tab is not visible for any users

2) PowerShell command does not recognize -Archive

Get-Mailbox -ResultSize unlimited -Filter {(RecipientTypeDetails -eq 'UserMailbox')} | Enable-Mailbox -Archive

The input object cannot be bound to any parameters for the command either because the command does not take pipeline in put or the input and its properties do not match any of the parameters that take pipeline input.
+ CategoryInfo          : InvalidArgument: (User Name:PSObject) [Enable-Mailbox], ParameterBindingException
+ FullyQualifiedErrorId : InputObjectNotBound,Enable-Mailbox

Tried running other PowerShell commands from other posts as well...

PS C:\> $mailbox=Get-Mailbox -ResultSize Unlimited -filter {RecipientTypeDetails -eq "UserMailbox"}
PS C:\> $mailbox | ForEach-Object {enable-mailbox -Identity $_.Identity -Archive}

A positional parameter cannot be found that accepts argument '-Archive'.
    + CategoryInfo          : InvalidArgument: (:) [Enable-Mailbox], ParameterBindingException
    + FullyQualifiedErrorId : PositionalParameterNotFound,Enable-Mailbox

 

PS C:\> Get-Mailbox User Name| FL *Archive*
ArchiveDatabase         :
ArchiveGuid             : 00000000-0000-0000-0000-000000000000
ArchiveName             : {}
ArchiveQuota            : 50 GB (53,687,091,200 bytes)
ArchiveWarningQuota     : 45 GB (48,318,382,080 bytes)
ArchiveDomain           :
ArchiveStatus           : None
DisabledArchiveDatabase :
DisabledArchiveGuid     : 00000000-0000-0000-0000-000000000000

What it appears to me is that I need Online Archive / Archive Mailbox enabled on my domain first? Any help would be appreciated.

Thanks,

  Justin

 

All Replies
  • Hi Justin,

    I understand you are facing the issue that unable to enable archive for mailbox.

    Could you provide the error info when you just run Enable-Mailbox user -Archive?

    Then, connect to Exchange Online through PowerShell,

    1), $a=Get-ManagementRoleEntry "Mail Recipients\Enable-Mailbox"

    2), $a.Parameters to check if archive is in the parameters list

    3), run Get-Mailbox | fl *plan* to check if all mailboxes in one plan.

    Thanks,
    Lester Zhang

  • Lester - Here are the results.  What I find interesting is the mailbox plan is referencing our initial domain mindspheretg.onmicrosoft.com.  I did setup all the email boxes on onmicrosoft.com first before migrating the domain name.  After our domain was migrated I changed the domain name on everyone's email address. Thanks, Justin

     

    PS C:\> Enable-Mailbox username -Archive
    A positional parameter cannot be found that accepts argument '-Archive'.
        + CategoryInfo          : InvalidArgument: (:) [Enable-Mailbox], ParameterBindingException
        + FullyQualifiedErrorId : PositionalParameterNotFound,Enable-Mailbox

    PS C:\> $a=Get-ManagementRoleEntry "Mail Recipients\Enable-Mailbox"
    PS C:\> $a.Parameters
    Confirm
    ErrorAction
    ErrorVariable
    Force
    Identity
    OutBuffer
    OutVariable
    WarningAction
    WarningVariable
    WhatIf

    PS C:\> Get-Mailbox | fl *plan*

    MailboxPlan : namprd06.prod.outlook.com/Microsoft Exchange Hosted Organizations/domain.onmicrosoft.com/Default-ec570cfb-a1e1-417a-8453-6207eccc2b4c

    MailboxPlan : namprd06.prod.outlook.com/Microsoft Exchange Hosted Organizations/domain.onmicrosoft.com/Default-ec570cfb-a1e1-417a-8453-6207eccc2b4c

    MailboxPlan : namprd06.prod.outlook.com/Microsoft Exchange Hosted Organizations/domain.onmicrosoft.com/Default-ec570cfb-a1e1-417a-8453-6207eccc2b4c

    MailboxPlan : namprd06.prod.outlook.com/Microsoft Exchange Hosted Organizations/domain.onmicrosoft.com/Default-ec570cfb-a1e1-417a-8453-6207eccc2b4c

    MailboxPlan : namprd06.prod.outlook.com/Microsoft Exchange Hosted Organizations/domain.onmicrosoft.com/Default-ec570cfb-a1e1-417a-8453-6207eccc2b4c

    MailboxPlan : namprd06.prod.outlook.com/Microsoft Exchange Hosted Organizations/domain.onmicrosoft.com/Default-ec570cfb-a1e1-417a-8453-6207eccc2b4c

     

  • Hi Justin,

    This may have been a temporary issue with the service.  Are you able to see the Mailbox Features and enable Archive mailboxes now?

  • No, I just checked.  It has been this way ever since we started on Office 365.

  • I also have this problem, and was about to post a question but found this thread instead.  I also migrated, with the domain originally being an onmicrosoft.com one.  Migration is now complete and we'd like to enable archive mailboxes, but the Mailbox Features option does not exist, and the PowerShell command fails as described here.

    Would appreciate instructions on how to enable the archive feature.

  • Can I please get your further assistance with this?

  • I've been asking about this too for a while with no clear answers.
  • I got a quasi-confirmation from my post in another thread.

    Evan Zhang MSFT Support  "Thanks for your information, we also tested and noticed this could be an issue. [...] And as far as I know, Anna is working on the Retention Policy icon disappearing issue in another thread, so you may discuss with her or you could open a new thread for individually discussion if needed."

    Disable All Retention Policies

    community.office365.com/.../146250.aspx

    I looked through Anna's activity however I could not find the thread he mentioned.

  • MSFT support...any update?

  • Can I please get some help?

  • As an update, this is being investigated internally at Microsoft and I am trying to find out what the current status is (it has been raised as a bug, but there is no more information at this time).

  • Hello Justin,


    Your post was responded to in a private message.



    • Please go to the Your Details section on the right side of the community site.

    • Click Private Messages.

    • Click the subject title of the response to read the message.

    • You can reply by using the form in this display.

    Thank you,
    Alexander Judd
    O365 Community Support

  • From the documentation I have seen, there may be a very simple answer.  As far as I can tell, archive mailboxes are not actually included in the P1 plan - they are only included in enterprise plans.  Does anyone have any documentation/statements they can link to that says otherwise?

  • Apparently it is with a powershell routine to configure it:

    "The Journal and retention policy feature are available for P1 plan now due to the service update from December 2011. The above workaround is still working. If there are more than one mailbox needed to be archived in a separate mailbox, we can run the cmdlets for these mailboxes one by one."

    http://community.office365.com/en-us/f/160/p/9124/38672.aspx#38672 

  • Thanks for the response.  Journaling and retention are a different feature to archive mailboxes, but I will look at the details of what was implemented in the December 2011 service update and see if I can get an answer there.