No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Synchronize calendar all-day-event iPhone->Exchange

This question is answered This question is answered

I tried synchronization of appointments and meeting requests from iPhone4s  to Outlook PC and from Outlook PC to iPhone, and that works fine.

 

Also, the synchronization of all day events from Outlook PC to iPhone works fine too.

The problem I have is that when I make a new all day event on my iPhone, it does not appear in my Outlook calendar.

Any solution for that? 

Verified Answer
  • I now updated my iPhone from iOS 5.0.1 to 5.1 and the problem was solved. So it was a bug in the iOS operating system.

    Case closed!

    Thanks to all for the help provided.

All Replies
  • Hi Turboman,

    Before moving on, I would like to confirm the following things to troubleshoot the issue you encountered.

    1. If the sync issue happens from the first beginning when you set up Exchange E-Mail on your iPhone?

    2. Have you ever been able to make a new all-day event on your iPhone and sync it to Outlook desktop successfully?

    3. If this event could not sync to Outlook desktop, could this event sync to Outlook Web App (OWA)?

    If it could not sync in OWA, to troubleshoot this issue, you might need to try to re-set up Exchange Active sync and re-create your ActiveSync profile on your mobile by following the article below:

    help.outlook.com/.../dd125429.aspx

    If this issue only happens in Outlook desktop instead of OWA,  I would suggest you recreate an Outlook email profile in Outlook desktop.

    Here is a KB about how to create and configure an email profile in Outlook 2010, Outlook 2007, and Outlook 2003:

    support.microsoft.com/.../829918

    Thanks,
    Anna Guo

  • Hello Anna,

    Thanks for your reply. Here are the answers to your questions.

    1. I only setup Exchange on my iPhone a few days ago, and this was my first test. I did not check sync of alldayevent before.

    2. Never did it before. This was my first test.

    3. Alldayevent could not sync from iPhone to OWA.

    I then followed your instructions: first deleted the Exhange account on my iPhone, resetup the Exchange active sync.

    However, afterwards, the problem is still the same.

    FYI: if I setup an alldayevent in OWA, then it syncs to Outlook 2010 on my PC. So I suppose my PC settings are OK.

    Have you tried to add an alldayevent in iPhone and sync from iPhone to OWA/Outlook?

    Or can anybody in this forum try to do this and confirm if it works or not? (note: it has to be an alldayevent, not an appointment. Appointment syncing works).

    Thanks

  • Hello Turboman,

    Thanks for your reply.

    Based on the current situation, I would also like to confirm if you are using any other software that manages your ActiveSync profiles on your device.

    Generally, all-day event should be able to sync between iPhone and Outlook Web App. It is likely that this has to do with the variances in ActiveSync profile apps that come with each device and iOS type. As each iOS implements the ActiveSync standard in its own way, there may be something different. Therefore, I would suggest you change to another mobile phone, test it and see if it works.

    Thanks,
    Anna Guo

  • hello Anna,

    Changing to another mobile phone is too expensive for a minor inconvenience.

    As a workaround, I will put in an alldayevent as an appointment.

    Thanks for your support, and no need to further continue this post.

    best regards,

    turboman

  • Hi Turboman,

    Thanks for your reply and additional feedback.

    If you have any other questions or concerns, please do not hesitate to contact us. It is always our pleasure to be of assistance.

    Thanks,
    Anna Guo

  • I think you might be making the All day appointment in the default calendar on your iPhone and this is almost never your outlook calendar.  Try this and see if it helps:

    Open the calendar app on your iPhone

    Look at the top left hand corner - See the button that says calendars - Push it

    Look at the calendars selected

    Do you have one for your exchange account?  If so proceed to the following

    Go to settings

    Go to Mail, Contacts, Calendars

    Scroll down to Calendars

    Look for DEFAULT CALENDAR

    Push on it and set your default calendar to your exchange account

    Now all appointments you make will default to your exchange account and sync accordingly

    NOW IF YOU DON"T WANT TO DEFAULT TO YOUR EXCHANGE ACCOUNT

    When making the appointment you can select which calendar you want it to appear on by doing the following

    When adding the new appointment BEFORE you hit done:

    Scroll down to Calendar and push it

    Select the correct calendar for the appointment (your exchange account)

    And then click on done

    Now it will sync back to your exchange account.

  • hello pipers4323

    Thanks for the input. But I had done everything you said already. I checked again, and it does not work

    There is another post that describes something similar:

    community.office365.com/.../33376.aspx

    I still have to check details of this post.

    As you are very specific in your description, I suppose you have an iPhone and an Exchange account. If yes, could you please check if you are able to input an alldayevent on your iPhone and sync to Exchange?

    Thanks, and best regards,

    turbomancould you please

  • Hi Turboman,

    I have checked the thread you posted, have you tried the steps Grace posted in that thread, does it help?

    Thanks,
    Anna Guo

  • hello Anna,

    As Grace recommended, I already setup the account again, with server name m.outlook.com

    I am hesitant to follow the other steps mentioned by Grace, with the Powershell commands, as I am not an experienced IT person.

    Since this problem only happens with alldayevents, but normal appointments and meeting invitations are syncing OK, I more suspect that there is a general problem with alldayevents, rather than my setup in iPhone/Exchange.

    So therefore before further experimenting with my setup, I would like to have confirmation from another user that an alldayevent input on their iPhone syncs OK.

    best regards,

    turboman

  • Hello Turboman,

    Does you iPhone device have same time zone setting with OWA and Outlook client?

    Based on my experience, this problem can be related to various factors, for example, the inconsistent time zone setting between mail clients (Outlook, OWA, mobile device), or corrupted ActiveSync relationship of mobile device. To narrow down this issue, I suggest you try the following steps and check if the problem can be fixed.

    1. Make sure the time-zone settings of all email clients are correct. To check time zone setting in OWA, you can refer to article Regional Tab.

    2. Refer to steps below to remove the device relationship from OWA to avoid corrupted ActiveSync relationship of mobile device.

    --Access your mailbox in Exchange Online with OWA.

    --Click Options>See All Options>Phone > Mobile Phones.

    --Remove your mobile devices from the Mobile Phones list.

    --Remove your Office 365 account from your phone.

    --After some time, re-add your Office 365 account on the phone and check if the issue can be fixed.

    By the way, if both normal appointments and meeting invitations are syncing properly among email clients, and all-day-event can be synced successfully between Outlook client and Office 365, it seems that your Office 365 mailbox works well. For a workaround, you can create the all-day-events from OWA/Outlook client, instead of from mobile device to reduce the impact of this problem.

    Additional Information
    ===============
    An Exchange Online mailbox calendar is not synchronized when you use an ActiveSync-based mobile device
    http://support.microsoft.com/kb/2293282

    iTunes for Windows: Issues with syncing all-day events after updating to iTunes 9.1
    http://support.apple.com/kb/TS3324

    iPhone and iPod touch: Syncing all-day events with Outlook may cause events to span two days
    http://support.apple.com/kb/TS1638

    Thank you.

    Jack Sun

  • Hello Jack,

    Thanks for the support.

    I did all the steps you said, but the problem is still the same.

    - set time zone the same for all clients (which in my case s Hong Kong).

    - Removed mobile devices in OWA -> remove Exchange account from iPhone -> after some time, re-add Exchange account to iPhone.

    The workaround using input in OWA/Outlook is not very comfortable.

    I would like to here from other users about their experience with inputting an all-day-event (as opposed to appointment) in the iPhone calendar, and confirm whether it works or not.

    Any user reading this: please help!

    best regards,

    turboman

  • Hi,

    Yes I have both an iPhone and Exchange account and I am able to input all day events and sync them with no problem; you just have to be sure  you pick the right calendar in the beginning.

  • Hello

    Thanks for the info.

    I am surprised that it works for you and not for me, even though I have selected the right calendar. The all-day-event shows up on the iPhone Exchange calendar, but does not sync to OWA or Outlook.

    However, an appointment (which has a start and end time) does sync properly.

    I have done everything that was suggested so far. I give up!

    best regards

    turbomen

  • I now updated my iPhone from iOS 5.0.1 to 5.1 and the problem was solved. So it was a bug in the iOS operating system.

    Case closed!

    Thanks to all for the help provided.

  • Hi Turboman,

    Thanks for your reply and additional description about how this issue is resolved.I have marked your answer as an answer for this issue.

    If you have any other questions or concerns, please do not hesitate to contact us. It is always our pleasure to be of assistance.

    Thanks,
    Anna Guo