No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Upload Center stuck - "Upload Pending"

  • 7 Followers
  • 21 Replies |
  • This post has 0 verified answers |
Answered (Not Verified) This question has suggested answer(s)

We're in the process of migrating a few file shares to SharePoint, a total of ~12.000 files/~7 GB.

 

To move the files we simply connected SharePoint document libraries with SharePoint Workspace and dragged and dropped the folders in. Just dragging and dropping files and waiting for the files to be copied to the Office Document Cache took the better part of two days (recurring problems with SharePoint Workspace and Upload Center hanging when dropping too many files in at once). It should be noted that the Internet connection being used is quite slow.

 

In the end we got all files showing correctly in SharePoint Workspace and all the files queued in the Upload Center. Along the way Upload Center seemed to be working properly and uploading files in parallel.

 

After a reboot of the PC, however, Upload Center now simply shows 'Upload Pending' for all remaining files. Selecting 'Upload' from the actions menu has no effect whatsoever. Clicking 'Upload All' freezes the whole Upload Center.

 

The Office Document Cache has grown from zero to 122 GB ~16.000 files (yes, 122 GB).

 

What to do? We would really prefer not to have to start all over by disconnecting the workspaces, clearing the cache etc.

 

And another question, what is the recommended approach to such migration scenarios?

  • Post Points: 20
All Replies
  • Hello

    it seems your content size is more important than the quota allowed (10 Gb of storage for SharePoint)

    If you have a Kiosk or Enterprise plan, you can buy additional storage

    Benoit HAMET

    Senior Solutions Architect

    MVP Office 365 - MCITP Office 365 - Microsoft Community Contributor

    Blog - Twitter

    • Top 75 Contributor
    • Post Points: 0
  • No, the size of the content is only about 7GB, and the quota set for the site collection is more than this.

    Please don't be confused by the 122 GB ODC. The 7GB I'm trying to upload has ballooned into 122GB in the ODC. Part of the problem I presume...

    • Not Ranked
    • Post Points: 0
  • Hi JornJ,

    The SharePoint Online service administrator can set the storage limits for site collections and sites created by users. The minimum storage allocated to a new site collection is 24 megabytes (MB). The maximum storage available for any site collection is up to 100 gigabytes (GB).

    The maximum SharePoint Online storage available to a single company’s tenancy is up to 5 terabytes (TB).

    File upload limit: 250 megabytes (MB) per file.

    If your files are over 100G, you cannot upload the files to a single site collection.

    Be noticed that, the Workspace’s max size is 2G and the total number of files you can store across all your SharePoint workspaces is approximately 10,000.

    Please refer to the links below:

    http://support.microsoft.com/kb/916412

    http://office.microsoft.com/en-us/sharepoint-foundation-help/synchronize-sharepoint-content-with-sharepoint-workspace-HA101854201.aspx?CTT=1

    Except using SharePoint Workspace, you can choose your document library in your team site, then in the ribbon, under “Library ”area, click “Open with Explorer”. A explorer windows will pop up. Thus, you can drag your files to the explorer windows.

    Thanks,

    Kylin Yang.

    • Top 150 Contributor
    • Post Points: 0
  • None of the information you give here is relevant to our problem:

    - We are only trying to upload 7GB (again, as stated in my previous post, the 122GB is what the ODC has grown to after adding 7GB to SharePoint Workspace).

    - The site collection quota is sufficient and there is sufficient space available before upload.

    - There are no files above 250MB

    - We are below the 10.000 file limit as well (I wrongly stated in my initial post that we had ~12.000 files. The correct number is 7.000)

    - It is not correct that the workspace max size is 2 GB. In the article in your first link it is specifically stated that there is no 2GB limitation on the libraries, but that the issue is related to Groove 2007 queuing.

    - The article is does NOT apply to SharePoint Workspace 2010 (see the 'Applies to' section).

    - Additionally, we are not trying to sync this workspace down, we are uploading.

    - The second link provides no further information - we are within all boundaries outlined in the 'Limits, exceptions, and workarounds' section.

    Jørn

    • Not Ranked
    • Post Points: 0
  • Hi JornJ,

    You can open your SharePoint Workspace, choose your team site in it, then under "Sync" area, click "Sync Status", you will find the status is "Credential required". Then you should click "Sync", a screen will pop up to let your input your Microsoft Online Services ID and password, after that, the files will be syncrhronized to your team site sucessfully.

    You can also try to use "Open with explorer" feature of SharePoint team site to drag your own files to team site.

    Please try to use the two methods to upload your files to team site, any issue please post back.

    Thanks,

    Kylin Yang.

    • Top 150 Contributor
    • Post Points: 0
  • Hi,

    There is no issue with the authentication - the 'credential required' steps are not relevant. The upload is simply stuck. Let me note that we have restarted the PC in question and re-authenticated to SharePoint, and the situation remains the same - all files are in 'pending' state, no uploads are happening.

    Regarding using WebDAV (Windows Explorer), thaw was the first method we tried. It's simply not resilient enough to handle this amount of data over the line we have at this location. Anyway, it is an alternative approach and won't help us in the current situation.

    It seems that the main issue has something to do with the Office Document Cache, and the size to which it grows. This simply cannot be normal behavior. As mentioned previously, on the PC where we originally found this issue the ODC has grown to 122 GB when we added about 7 GB to SharePoint Workspace. We have now been able to reproduce this behavior on another PC (with a high-speed Internet connection), where adding approximately 2-3GB of files to SharePoint Workspace (drag and drop from Windows Explorer) has led to the ODC ballooning to more than 45 GB.

    We've experimented with adding folder by folder, and dropping a ~100MB folder into SharePoint Workspace results in the SP Workspace freezing for a minute while the files are added, during which time the ODC grows maybe 2 or 4 GB (ie. 20 to 40 times the actual size of the files). It seems on both PCs most of this growth ends up in a single FSD file in the ODC cache (on one PC 110 out of 120 GB is in one file, on the other 40 out of 45 GB).

    Disconnecting the document library in question in SharePoint Workspace has no apparent effect on the size of the ODC. Even using SharePoint Workspace to delete the entire library does not reduce the cache significantly. I'm not sure whether this is standard behavior.

     

    When syncing the document library on another PC which has not been involved in the uploading the size of the ODC, once the sync is completed, corresponds with the actual size of the files.

     

    Note that on the second PC we are not experiencing the problem of uploads hanging, otherwise the behavior is identical.

    Both PCs are Windows 7 Enterprise w/SP1, Office 2010 Professional w/SP1 (both fully patched).

    • Not Ranked
    • Post Points: 0
  • Hi again,

    One more thing... Going to Upload Center -> Settings and trying to delete cached files has no (visible) effect on the size of the ODC (although the command seems to work - no error messages).

    Jørn

    • Not Ranked
    • Post Points: 0
  • Hi JornJ,

    For your situation, you stated that in another pc anything is normal.

    So, there must be something wrong with your previous pc.

    Please paste the command to your windows explorer address bar:

    %userprofile% \AppData\Local\Microsoft\Office\14.0\OfficeFileCache, you can delete the Office File Cache manually.

    You can also  change the default location of the Office 2010 Document Cache if you like.

    Then you can change Office Document Cache settings. Clear Office Document Cache and then prevent Office Document Cache from retaining closed documents.

    To clear Office Document Cache, follow these steps:

    1. Click Start, point to All Programs, and then point to Microsoft Office.

    2. Point to Microsoft Office 2010 Tools, and then click Microsoft Office 2010 Upload Center.

    3. On the Settings menu, click Delete cached files.

    4. Click Delete cached information to confirm the deletion of the files.

    To prevent Office Document Cache from retaining closed documents, follow these steps:

    1. Click Start, point to All Programs, and then point to Microsoft Office.

    2. Point to Microsoft Office 2010 Tools, and then click Microsoft Office 2010 Upload Center.

    3. On the Settings menu, click Delete files from the Office Document Cache when they are closed.

    After you clear Office Document Cache, wait until the last saved document is uploaded to the SharePoint library before you open the document that you want.

    For Office Document Cache settings, please refer to the link: office.microsoft.com/.../office-document-cache-settings-HA010388664.aspx

    For more information about Upload Center, please refer to the link: office.microsoft.com/.../CL101845606.aspx

    After that, please retry the Upload Center to check whether it works.

    Thanks,

    Kylin Yang.

    • Top 150 Contributor
    • Post Points: 0
  • Hi again,

    We ARE experiencing this problem on both PCs. I am here referring to the disproportionate growth of the ODC. It is correct that only one PC had the 'Upload pending' issue. This issue in itself has alrady been 'resolved' by manually deleting the ODC, so what we are interested in now is how to fix the growth of the ODCs.

    In the mean time we have also reproduced the issue on a third PC with the same software configuration: dragging and dropping files into SharePoint Workspace results in the ODC growing to 20-40 times the actual size of the files, and almost all of the growth happening in a single FSD file. We have tried this numerous times now, with various combinations of waiting for all files to be uploaded, rebooting in between etc., and whatever happens the ODC never shrinks back to a reasonable size (meaning to anything close to the actual size of the uploaded files).

    Neither of the following approaches have any discernible effect on the size of the ODC:

    - The 'Delete cached files' option in SharePoint Workspace

    - Disconnecting the workspace from SharePoint Workspace

    - Deleting the entire content of the document library from SharePoint Workspace

    - Deleting the content of the document library server side and syncing in SharePoint Workspace

    In every case the single huge FSD file remains the same size.

    Reiterating from my previous post:  syncing an existing document library to SharePoint Workspace results in the size of the ODC being the same approximate size as the files in the library.

    Manually deleting the OfficeFileCache folder 'works' in the sense that the cache is cleared, but it doesnt resolve the situation. Whenever more files are added through SharePoint Workspace again, the ODC balloons to 20-40 times the size of the actual files, so this is not a solution to the underlying problem.

    The option 'Delete files from the Office Document Cache when they are closed' seems to defeat the whole purpose of using SharePoint Workspace to take the document library offline in the first place, and at best would be a workaround for uploads.

    In short, as I cannot imagine that the growth of the ODC to 20-40 times the size of uploaded files, combined with the 'Delete cached files' not working is as per design (and the same behavior being reproduced on three different PCs), there seems to be a bug here somewhere.

    Jørn

    • Not Ranked
    • Post Points: 0
  • Jørn - I'm having the same problem on all my systems. People need to read what you write a little more closely!

    • Not Ranked
    • Post Points: 0
  • Hi Jorn,

    Could you try this (Office 2010: Fix Office Document Cache Error): www.addictivetips.com/.../office-2010-fix-office-document-cache-error ?

    Coco

    • Not Ranked
    • Post Points: 0
  • @Coco Didn't work for me. Hopefully, it helps Jorn. Thanks for suggesting something pertinent, even if it didn't work for me.

    • Not Ranked
    • Post Points: 0
  • Hi Coco,

    Thanks for the tip!

    I'm not sure whether this is s proposed fix for the original "Upload pending" or for the ballooning ODC. I resolved the "Upload pending" by simply deleting the ODC, so can't say if this would have worked.

    In any case I tried your suggestion on two of the test machines but unfortunatley it doesn't do anything to the ODC growth issue.

    Jørn

    • Not Ranked
    • Post Points: 0
  • Hi JornJ,

    We are very glad that the "Upload pending" issue is resolved.

    However, for the ODC growth issue, please feel free to submit a feedback by clicking "Feedback" button at the right lower corner of the Forum.

    Any update for the issue, I will post back.

    Thanks,

    Kylin Yang.

    • Top 150 Contributor
    • Post Points: 0
    Suggested by
Page 1 of 2 (22 items) 1|2|