SharePoint online workflow email not sending

This question has suggested answer(s) This question has suggested answer(s)

Hi,

Am using the office365, sharepoint online 2013. In that i created a  custom workflow for to send email using SPD.

Now in my scenario is i have migrating users mailbox from on premises to cloud mailbox.

So that my workflow mails not going for non migrated users i.e on premises users. it working only for migrated users only i.e users having mailboxes in cloud.


Can anyone tell me how to send mailto non cloud users i.e onpremises users( having mailbox in exchange server 2003).


Thanks,

rk.



All Replies
  • Hi RK,
    Before moving on, I want to collect following information:
    1. Which migration method did you use?
    2. Have you tried creating a workflow to send mail to an external address?
    3. Which version of SharePoint Designer do you use?

    Thanks,
    August Sun

  • Hi August Sun,

    Thanks for your reply.

    Please have a look on this below information's.

    1. For migration am not having exact idea on method of migration.

    2.Tried creating a workflow to send mail to an external address - working fine.

    3. SharePoint Designer 2013.

    4. SharePoint version -  4 (15.0.0.4454)

    With Regards,

    RK

  • Hi RK,

    You may try to narrow down the issue by referring to the following KB article: Users don't receive SharePoint Online alert notifications.

    In addition, you can open the workflow in the SharePoint designer, open task list and history list to check the status of the workflow. If there is any error messages returned, please post here for further troubleshooting.

    Thanks,
    Allen Qiu

  • Hi RK,

    I am writing to follow up on my previous reply. Please feel free to post in this thread if the issue persists.

    Thanks,
    Allen Qiu

  • Hi Allen,

    I am facing the issue of the emails not being sent to external email addresses using sharepoint workflow. here is the error reference, please let me know if i am missing anything

    RequestorId: be76ca65-ac75-53e6-0000-000000000000. Details: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.ApplicationException: HTTP 400 {"Transfer-Encoding":["chunked"],"X-SharePointHealthScore":["0"],"SPClientServiceRequestDuration":["322"],"SPRequestGuid":["be76ca65-ac75-53e6-b7ec-cde18b6654f8"],"request-id":["be76ca65-ac75-53e6-b7ec-cde18b6654f8"],"X-FRAME-OPTIONS":["SAMEORIGIN"],"MicrosoftSharePointTeamServices":["15.0.0.4454"],"X-Content-Type-Options":["nosniff"],"X-MS-InvokeApp":["1; RequireReadOnly"],"Cache-Control":["max-age=0, private"],"Date":["Mon, 08 Apr 2013 18:43:02 GMT"],"P3P":["CP=\"ALL IND DSP COR ADM CONo CUR CUSo IVAo IVDo PSA PSD TAI TELo OUR SAMo CNT COM INT NAV ONL PHY PRE PUR UNI\""],"Server":["Microsoft-IIS\/7.5"],"X-AspNet-Version":["4.0.30319"],"X-Powered-By":["ASP.NET"]} at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) in d:\bt\103818\private\source\WF\Microsoft.Activities.Hosting\Microsoft\Activities\Hosting\Runtime\Subroutine.cs:line 282 at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

    thanks

    kothand

  • Hi kothand,

    It should be an by design behavior in SharePoint Online, the Email address we using in the workflow should be an internal Email address, which requires an Exchange Online license. If you have any concerns about this feature, you may send feedback on the Office 365 website with the following link:
    http://mymfe.microsoft.com/Microsoft%20Online%20Services/Feedback.aspx?formID=210

    If the service is requested frequently, the product team may include it in the future releases. Your useful ideas and feedback will help us improve our products and service. Your time and efforts are highly appreciated.

    Thanks,
    Allen Qiu

  • Hi karthick

    I am new to SPWorkflows.

    Please can you share steps (Code) for  creating a workflow to send mail to an external address.

    Thanks in advance

    Regards,

    Shree

  • Hi Shree,

    Workflow created using SPD 2013 will not able to send email to external users.

    However you can achieve it by creating a SharePoint 2010 reusable workflow for sending email and deploy it to SharePoint 2013 Online.

    SharePoint 2010 reusable workflow on SharePoint 2013 Online will able to send email to external users.

    Thanks

    Jhalak

  • Hi Shree,

    Workflow created using SPD 2013 will not able to send email to external users.

    However you can achieve it by creating a SharePoint 2010 reusable workflow for sending email and deploy it to SharePoint 2013 Online.

    SharePoint 2010 reusable workflow on SharePoint 2013 Online will able to send email to external users.

    Thanks

    Jhalak

  • SharePoint SPD Workflow cannot send email to external users. But it is possible with help 3rd party solutions. One of it is Plumsail Workflow Actions Pack that is contains Send an Email with attachments that support sending email to external users.