When I assign a task it does not send an email

This question is answered This question is answered

I have assigned a task in the out of-the-box Task list but no email gets sent. I have checked the list options to make sure the setting is enabled for this but it does not work. I cannot sen to find anywhere to setup email addreses for users other than the login id (my domian is verfied). Is there somewhere I have to setup sharepoint online to point to my domain SMTP server?

 

Thanks in advance

Grant

1 out of 1 people found this post helpful.

Verified Answer
  • Hello again Grant,

    Glad to hear the issue was resolved!  The sync between your Tenant Admin (where you have changed the work email) and your SharePoint site collections should occur automatically within the time frames that are setup on the server side.  If you make a change and it does not take within 24-48 hours it may be stuck and the customer will not have access to a forced sync.  This will require you to create a support case to look into the issue if it was to become apparent again.  Let us know if you have any further concerns.

    Thanks,

    Justin Ronan

    Microsoft Office 365 SharePoint Support

All Replies
  • Hi

    In Task Lists's properties can you check if "Send e-mail when ownership is assigned?" is "Yes" .. if its is Yes set it No and then come back and set it to "Yes"

    3 out of 3 people found this post helpful.

  • Hi Grant,

    Based on your description,I understand that you've assigned a task but no email gets sent.

    First,You can try to follow Isha's solution.

    Then I would like to confirm some things.
    (1),If you have already set up a workflow for a list.
    (2),Have you ever set up a workflow for a list? If so, did the workflow have been removed?
     
    Please check that if your workflow is working fine. At the same time, please make sure the “√” had been marked in front of the two options of “Start this workflow when a new item is created” and “Include Task Assigned To” that in the “Workflow settings” page.

    Thanks,

    tomttt

  • I tried that. Set to "no" and saved, went back in and set back to "yes" and created a new test task and I still don't receive an email.

    Where so you actually setup email addresses for sharepoint users anyway? In the online service admin portal there is no place to provide the User email address for the account. It has address, contact numbers etc, but nowhere to provide the email address, so how does sharepoint online know the email addresses since I'm not running Exchange. I used to host a sharepoint 2007 server on premise and you could setup the STMP gateway addresss for email, but I cant find this in sharepoint online.

  • Hi Tomttt, re prvious, I didnt check the workflow settings, but I just checked and there is no workflow associated with the list. Not sure why this would be needed as with my on premise 2007 site it works fine and does not have any workflows associated with the list?

    regards

    Grant

  • hey

    can you try creating an alert for the user whom you are assigning the Task to ... just need to check if the e-mail is working for your Task list and for that user..

  • I went to set an altert and noticed that the email address that the alert is to be sent to for my user is username@company.onmicrosoft.com which is why emails are not working. How do I change this to email my domain email address?

  • Hi granvista,

    To change username@company.onmicrosoft.com to your own domain you need:

    1.       Login your Microsoft Online Protal

    2.       Click user under Management at the left panel

    3.       Choose the user/users you want to edit

    4.       Click edit button on top of user list

    5.       Select Detail section

    6.       You can change your email domain here


    Cheers,
    Te-Amo
  • I had already changed the email domain but it still refers to the old one, it has not changed it.

  • Hi granvista,

    Before moving on, I'd like to confirm the following information:
    1.What's subscription you are using? P plan or E plan?
    2.You mean you would like SharePoint send email to your custom email address instead of @domain.onmicrosoft.com, is it correct?
    3.What's email service you are using? Exchange Online or on-premise Exchange Server or hybird deployment?

    You can confirm what's the email address related to SharePoint Online by doing the following steps:
    Log into SharePoint site>Click your name in the top right > My Settings
    The third line show you the email address.

    If you want to change it, I assuming that you are using Office 365 for enterprise subscription, please do the following steps:
     1. Login MOP at http://portal.microsoftonline.com/ as global administrator.
     2. Click Manage under SharePoint.
     3. Click Manage User Profiles.
     4. Click Manage User Profiles under People.
     5. Select who you want to modify the email address and change the Work e-mail.
    After doing this, the setting will be synced to My setting within 24 hours.

    For P plan user, please directly change the work email address in My setting>Edit Item.

    If there are anything unclear, please feel free to contact us.

    Thanks,
    Allen Qiu

  • Hi Te-Amo, yes I had already done this and my domain (not the microsoft.com omne) is the primary domain but makes no difference.

  • Hi Allen,

    I did all of this but even when my work email is a valid address for my domain (e.g. me@mycomany.com) the system still uses the me@mycompany.onmicrosoft.com domain. When I set an altert on a list it still uses the onmicrosoft.com domain, even though I have setup my domain as the primary and it reports that my domain is the primary domain.

    regards

    Grant

  • Allen,

    one other thing, I am running a sharepoint P2 plan. When I changed the email addresses via the User Profile section it updated the email address shown via "My setting>Edit Item". Also, going in via the "my Setting>edit item" won't actually let me "edit" anything, I only get to view the settings.

    I did start off with an E3 trial and then decided just to purchase the Sharepoint P2 plan. Not sure if this has anything to do with the issue. I don't have any licences of the E3 plan anymore although it still shows up in the Admin screen as selectable and says 20 of 20 licences available but the trial has expiered. I have no users assigned to these licences.

    All users are only assigned to Sharepoint Plan 2 licences.

    regards

    Grant

  • Hi granvista,

    Based on your description,I understand that you are running a sharepoint P2 plan.Can you post a screenshot of you work-email.
    As Allen said,If you want to change your work-email,Please follow the steps:
    1. Login MOP at http://portal.microsoftonline.com/ as global administrator.
    2. Click Manage under SharePoint.
    3. Click Manage User Profiles.The following diagram may help:

    4. Click Manage User Profiles under People.The following diagram may help:

    5. Select who you want to modify the email address and change the Work e-mail.The following diagram may help:

    Note:After doing this, the setting will be synced to My setting within 24 hours.
    If this issue persists,please feel free to contact me.

    Thanks,
    Tom

  • Hi Grant,

    How are things going on your side? If you need further assistance on this issue, please feel free to contact us.

    Thanks for your efforts.

     

    Thanks,

    Jerry Cen

  • Still not working, I changed the work-email as suggested above 3 days ago via the user profiles configuration to username@mycompany.com.au.

    When I login to my team site and click on my name in the upper right corner and click on "my settings" the email address is still wrong - it is still using the domain mycompany.onmicrosoft.com (SIP address, Work e-mail and username) which was the original domain when I setup the plan. I have since changed the Primary domain to mycompany.com.au which is working fine for logins etc but not for email.

    My user Account is "i:0#.f|membership|username@mycompany.com.au" which is using the correct domain.

    regards

    Grant