No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Why is _themes folder accessible in some P1 accounts not others?

This question is answered This question is answered
I can use SPD to access stylesheets in some P1 accounts via the _themes folder but it doesn't appear in all accounts. WHY?
Verified Answer
  • Hello Mchv2.0,

    The _themes folder is not a default folder in SharePoint Designer 2010. For the _themes folder to show up under All Files in SharePoint Designer 2010, you add a custom theme to the Site Theme option under the Look and Feel label in your Website Site Settings.

    I will continue to monitor this thread for further posts or questions.

All Replies
  • Hello Mchv2.0, 

    This is Jason Burnside from Microsoft Office365 SharePoint Support.

    Thanks for coming to the communities with your concerns about accessing the _themes folder through the style sheets option in SharePoint Designer 2010.

    Unfortunately, I am unable to reproduce your issue. When I click on the Style Sheet option on any website page and click view default CSS, it brings me to the theme.css page in SharePoint Designer as long as I have SharePoint Designer open.

    I will continue to monitor this thread if you have any additional questions.

  • Jason,

    Sorry but that wasn't what I asked. You have css files set to open in SPD. By default they open in notepad. If I change the program associated with css files to open in SPD, yes the default css file opens in SPD.

    But my questions was: why is the _themes folder available in some accounts and not others?You can clearly see the difference in these 2 screenshots - 2 differnet P1 accounts logged in as admin:

      

     

     

  • Hello Mchv2.0,

    I do not have the “_themes” or “365Themes” folders in top-level of the All Files folder in SharePoint Designer 2010 for my public-facing website however my themes folder is in the “_catalogs” folder in the All Files folder.

    I will continue to monitor this thread for further posts or questions.

  • Jason,

    _themes and theme

    are not the same thing. You're talking about the team site theme folder which is in catalogs and isn't of much use.  I mean the _themes folder that contains all the default css files.

    As you can see from the screen shot it's at the root of some accounts I've seen but not others. Why is that?

     
  • Hello Mchv2.0,

    Our team supports connecting a website or site collection to SharePoint Designer 2010 however we do not support SharePoint Designer 2010. Unfortunately, I do not have the answer for you however it may show up if there is custom CSS on the website.

    I will continue to monitor this thread for further posts or questions.

    1 out of 1 people found this post helpful.

  • SPD doesn't determine the structure/permissions of a 365 account, so the question isn't about SPD. The custom css file is in the Resources folder for both accounts (when activated) but there are a whole bunch of other css and image files available under _themes/37 in one account but not the other. So the questions remains: why is that and how do I get consistency across accounts? 

    1 out of 1 people found this post helpful.

  • Hello Mchv2.0,

    The _themes folder is not a default folder in SharePoint Designer 2010. For the _themes folder to show up under All Files in SharePoint Designer 2010, you add a custom theme to the Site Theme option under the Look and Feel label in your Website Site Settings.

    I will continue to monitor this thread for further posts or questions.

    1 out of 1 people found this post helpful.

  • Ok that worked. Is that documented somewhere? If not how would someone figure it out? 

    1 out of 1 people found this post helpful.

  • Hello Mchv2.0,

    Unfortunately, I did not find documentation regarding this issue. I found out by testing.

    I will continue to monitor this thread for further posts or questions.

    1 out of 1 people found this post helpful.