No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Link does NOT open in new window

  • This post has 6 Replies |
  • 5 Followers
  • I have hyper-linked items within my site and have selected the option to have it open a new window when selected, however, it does not open a new window at all. I have tried it both with the option selected and without it and same result. I am concerned that this will make it challenging for potential clients to remain interested in utilizing my site if they must continually use the "back button" to return to my site. Any suggestions or info as to why this selection is not performing as it should? Thank you.
  • Hi Christopher,
    This is Bob Kasper from Microsoft Office 365 SharePoint Support.  Thank you for addressing your concern about the Hyperlinks not opening in a new window.  To help me narrow down what could be causing this issue I will need you to answer a few questions.

    1.      Are the hyperlinks in the team site or the public facing site?

    a.      If it’s the public site may I get the URL so I can see them?

    b.      If this is happening on the internal site please explain how the links are created. 

    2.      Does it happen on all computers?

    Thank you,
    Bob Kasper
    Microsoft Office 365 SharePoint Support
  • Hi Christopher,
    I’m just checking in to see if you have been able to resolve your issue about the hyperlinks not opening in a new window. 
    As I mentioned in my last post, to help me narrow down the cause of this issue I will need the questions answered from above. 
    Please let me know if you still need assistance on this issue as I will be watching this thread for the next few days. 
    Thank you,
     
    Bob Kasper
    Microsoft Office 365 SharePoint Support
  • Hi, Bob:

    I'm having the same issue I think. I created the link in my public facing website using a document uploaded to my "documents" section of the team site. It's a PDF file. I'm on Explorer for the web browser. When I try to open the link (pretending to be a visitor on my site) it asks to "save" the file rather than open it. Any help would be appreciated. Thanks.

  • ECAdmin,

    That's a different issue.  365 won't allow pdfs to be opened in the browser. There's a solution here but I don't think it works in the public site docs library.


    http://webbrewers.com/   |     |  Get more out of Office 365

  • Hi ECAdmin,
    Thank you for bringing your concern about PDF files not opening in the Browser. 
    As MCH pointed out this does not work, in the Standard Service Description it gives the reason why MSFT decided not to have them open in the browser. 
    Please let me know if there is anything else that I can assist you with as I will be monitoring this thread over the next few days and will reply as soon as possible.
    Thank you,  
    Bob Kasper
    Microsoft Office 365 SharePoint Support
  • Hi Bob,

    I am having the same issue with a subsite  created in SharePoint 2013 online that is impacting both internal and external links.  The open new window option is working just fine with the main site however it is not working with the subsite from any computer and using different browsers.  I hope you can help resolve this issue as it is extremely vital for our company to have specific links open in a new window.  

    Thank you in advance,

    Yasser

Page 1 of 1 (7 items)