No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Has anyone succeeded using webservice in InfoPath on office 365?

  • 8 Followers
  • 15 Replies |
  • This post has 2 verified answers |
Answered (Verified) This question is answered
Ive tried everything but still cant get it to work, maybe its not possible yet?
Conny Bark | CEO/Lösningsarkitekt | M&B Portal solutions conny@mbportal.se | Mobil: +46 (0)709 630 394 | Telefon: +46 (0)455 32 28 28 | Websites: www.mbportal.se / www.webity.com
  • Post Points: 35
Verified Answer
All Replies
  • Hello Conny,

    Which web service template you used in the InfoPath? It seems that InfoPath supports both SOAP and REST Web services. However, only SOAP Web services can be used as the primary data source.

    If you want to use the web service to receive or submit data, you may refer to the following articles.

    Overview of form templates and modes in InfoPath

     

    InfoPath and Web Service data connection
    http://blogs.msdn.com/b/jannemattila/archive/2007/01/21/infopath-and-web-service-data-connection.aspx

    Creating a web service for an InfoPath form in 25 easy steps
    http://blogs.msdn.com/b/philoj/archive/2005/11/08/490200.aspx

    Sky

    • Top 500 Contributor
    • Post Points: 0
  • I tried Soap and lists service to get list items. But it seems it wont connect to the serivce. I have no problem with this when i do it On Premise. so its seems to me its a Office 365 problem. A workaround would be as in the article to build a externa webservice.

    Conny Bark | CEO/Lösningsarkitekt | M&B Portal solutions conny@mbportal.se | Mobil: +46 (0)709 630 394 | Telefon: +46 (0)455 32 28 28 | Websites: www.mbportal.se / www.webity.com
    • Not Ranked
    • Post Points: 0
  • found other with same error as me, community.office365.com/.../2377.aspx

    Conny Bark | CEO/Lösningsarkitekt | M&B Portal solutions conny@mbportal.se | Mobil: +46 (0)709 630 394 | Telefon: +46 (0)455 32 28 28 | Websites: www.mbportal.se / www.webity.com
    • Not Ranked
    • Post Points: 0
  • Hello Conny,

    Your post was responded in a private message with a subject of “Information Request: Re: Has anyone succeeded using webservice in InfoPath on office 365? ".

    Please go to the Your details section on the right side of the community site.

    Click Private messages.

    Click the subject title of the response to read the message.

    You can reply by using the form in this display.

    Thank you.

    Jack Sun

    • Top 50 Contributor
    • Post Points: 0
  • I am having the same problem.  When connecting via SOAP, I see the full list of services but when I attempt to use them I get the following error:

     

    An error occurred while trying to connect to a Web service.

    An entry has been added to the Windows event log of the server.

     

    I'm trying to use the GetUserProfileByName webservice method in order to populate a Person object with the current user's AccountID and PreferredName; the goal being to have a PersonPicker default to the current user if the object is blank when the InfoPath form loads.  It works just fine on my local SharePoint 2010 environment, but the service call fails with SharePoint Online. 

     

    Is there a solution to this issue?

    • Not Ranked
    • Post Points: 0
  • Jack,

    May I ask what is the point of a public forum, when you are private message to respond?

    How will other like Jorin below who has the same problem learn if you or Conny do not make a response public here?

    Hope this helps

     

    Robert

     

    • Top 50 Contributor
    • Post Points: 0
  • Hi Robert,

    As soon as I find a solution i will post it here.

    // Conny

    Conny Bark | CEO/Lösningsarkitekt | M&B Portal solutions conny@mbportal.se | Mobil: +46 (0)709 630 394 | Telefon: +46 (0)455 32 28 28 | Websites: www.mbportal.se / www.webity.com
    • Not Ranked
    • Post Points: 0
  • Hello Robert,

    Thank you for letting me know your concern.

    Due to many users have encountered the same problem and the complexity of the issue, I would like to have the detailed problem description and customer’s domain information for further. Because the customer’s domain information is not suitable for posting in a public forum, I sent the private message to request these information. Sorry for the unclear in my previous post.

    I will keep working on this issue and post the result in this thread if any update.

    Thank you.

    Jack Sun

    • Top 50 Contributor
    • Post Points: 0
  • Hi All,

    I have done some background research for this problem, and notice that:

    The root cause of this problem is that "Business Data Connectivity Service" feature is required when trying to get data using web service in InfoPath. However, currently, for security purpose, the Business Data Connectivity Service is not part of the Office 365 SharePoint Online offering. You can find the available features in SharePoint Service Description, which can be found at following link:

    Office 365 for Enterprise Service Descriptions

    http://www.microsoft.com/download/en/details.aspx?id=13602

    For a workaround, you may refer to Sky’s suggestion to build an external webservice. If you have any concern about this future, I suggest you submitting a feedback at <http://mymfe.microsoft.com/Microsoft%20Online%20Services/Feedback.aspx?formID=210>.

    Thanks all for your understanding and patience.

    Jack Sun

    • Top 50 Contributor
    • Post Points: 0
  • Jack,

    Just to be clear...  Are you saying that the work-around is to create a webservice that calls the Office 365 SharePoint web services for the InfoPath form to consume?  That the Office 365 SharePoint web services will work as long as InfoPath is not the direct client?

    • Not Ranked
    • Post Points: 0
  • Hello Jorin,

    Yes, you are correct.

    Just as I mentioned in the previous post, since "Business Data Connectivity Service" feature is not supported in SharePoint Online offering, there is no an official solution to do that. For a workaround, you can refer to Sky’s suggestion to build an external webservice. Note: this workaround may require an extra server.

    Thank you.

    Jack Sun

    • Top 50 Contributor
    • Post Points: 0
  • We have built that kind of solution but as you say it requires a extra server and its not so flexible when you have to use a service to connect to another service.

    But thanks for the help Jack and i really hope this is going to be fixed soon. Rest-service dont work aswell.

    // Conny

    Conny Bark | CEO/Lösningsarkitekt | M&B Portal solutions conny@mbportal.se | Mobil: +46 (0)709 630 394 | Telefon: +46 (0)455 32 28 28 | Websites: www.mbportal.se / www.webity.com
    • Not Ranked
    • Post Points: 0
  • Hello Conny,

    Thank you for your feedback and clearing the workaround for this problem.

    Your feedbacks are very important for us. Please understand that we strive to improve our product quality and solve the problems to the best of our abilities. Having said that we really appreciate your feedback on this issue.

    Jack Sun

    • Top 50 Contributor
    • Post Points: 0
  • Jack - it is really unacceptable that such a core ability is disabled in SharePoint on Office 365. Using SharePoint's own web-services in a browser based InfoPath form for such common tasks as obtaining user's group membership, account info, permissions, etc. etc. is very key.  This will likely loose us a customer who is hoping to move to Office365.

    • Not Ranked
    • Post Points: 0
Page 1 of 2 (16 items) 1|2|