No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Adding a blog to a public facing website

  • I'm currently in a discussion with the O365 bug fix group about this issue. They are raising it as an issue but I’m not confident that it will amount to much unless others report this as a problem. I'd like to suggest that each of you create a new service request using the following link:

    *edit* Removed the link to create service requests, this should be posted by Microsoft Moderators only.

  • I also submitted a request. let's see if anything happens

  • You can easily create a sub site of the public site with the blog template, but the problem is it's coded to access the comments/categories lists which reside on the team site. So the result is they trigger a log in.

    I believe the code is on the server and is inaccessible to 365 tenants. While the permissions issue will prevent that being changed, it should be possible to recreate the blog components in SPD. 

    We plan on trying to do that but if anyone else has any other suggestions they'd be appreciated. . 

  • mch,

    Regardless where they live, the problemis the anonymous user only has read access so they will not be able to leave a comment.

  • So the solution should be:

    * Custom Master Page (to change the OOB link behaviour)

    * Sandbox Webpart (to allow comments to be saved?)

  • A soultion has been posted in the following post - community.office365.com/.../49272.aspx

    ****

    Martin had a wonderful blog written out. I was designing my site and stumbled upon this free webpart that does grant all the required privileges for any list/document library

    shopsharepoint.com/.../43-sharepoint-online-how-to-enable-anonymous-access-to-a-list-or-a-document-library-on-your-office-365-sharepoint-website.aspx

    ****

    I've implemented this on my blog sharepointpm.net and all works well. :-)

  • Does this work for a P1 account or only enterprise?  I have tried this and another solution I have found, but I still get asked to log in when I go to the blog site.

  • It works on any account. There's a more complete explanation here:

    Create a public blog site in Office 365

     

  • mch, i tried that solution, but it still asks me for a log in when I go to my site

  • Craig,

    Make sure you're in the public site when you create the blog subsite. The "posts" page should then come up anonymously whether you use the solution or not. If that doesn't work, something else could be wrong.  

  • oops, i was creating at the teamsite level.  It works now, Thanks!!!