No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Can't log in to public SharePoint Online website: 404 not found

This question is answered This question is answered

Hi. The public site collection feature just got enabled on my beta account. So I registered a domain name in the Office 365 administration site then went to SharePoint Online administration and created a new public website using the domain name.

The site created fine and I was able to view it. But, when I clicked the Member Login link I got a 404 not found error. My browser got redirected to this page: https://www106.sharepoint.com/_layouts/landing.aspx

Verified Answer
All Replies
  • Hi Myles,

    The addition of "Domain Intent" is new in MOP.  
    Did you set the intent for that new domain as "SharePoint Online"?

    Cheers,
    David

  • Hi David,

    Yes, I unchecked Lync and Exchange and checked SharePoint Online for the domain intent.

    I was then able to create a new public site collection and select my domain.

    Thanks,

    Myles

  • Hi David. Any news on this? This is still a problem.

    One new piece of information: I am able to login in fine to the default thinkscape-web.sharepoint.com address but when I create a public facing website using my custom domain e.g. http://www.mydomain.com then I get the error when I try to login in to the site.

    Thanks,

    Myles

  • Hi Myles,

    When you set the "Domain Intent" to sharepoint, did you make the required DNS changes?

    Check under "Domain Intent" and "DNS Settings" for the needed settings.

    David

  • I don't see this "domain intent". I just added a domain, set up the dns and it worked for both public and team site:

     http://


    Domain intent doesn't appear in my admin/domain area. Where is it?

  • Could you log in to your public web site though?

  • Hi David. I made the DNS changes as per the instructions in the SharePoint Online admin portal. There are no instructions in the DNS Settings in the portal administration site - just some "about DNS" information.

  • Hi mch. Which plan are you on? I am using E3.

  • Myles,

    Plan is P1.

    I can log in to the member sign in on te public site if that's what you mean. It opens the team site. I've a feeling that's not what you mean though.

  • Hi mch. Thanks for getting back to me on that. It's exactly what I mean - I am not able to log in to the member sign in on my public site on the E3 plan but you are able to on the P1 plan. So I can't edit pages or change settings.

    I think I set up all the DNS configurations correctly so it could be down to a difference in how the P1 and E3 plans handle public sites. I am going to escalate via beta support.

  • Not sure if this is relevant but according to this video, you can only add a domain in a 365 for Small Businesses account (which is I assume what P1 is and what I have).  
    http://community.office365.com/en-us/b/office_365_technical_blog/archive/2011/04/01/video-adding-a-registered-domain-name.aspx