No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Cannot add external users

  • This post has 11 Replies |
  • 4 Followers
  • I am currently using a trial of the Office365 E1 subscription and I am trying to add an external user.  I've already activated "External user invitations" in the Site Collection Features page, but when I go to add the user's email, I get the following error message:

     

    "Invitations to users outside your organization are currently disabled."

     

    Any ideas on why it's not working?

  • Hello JMventures,

    This is Jason Burnside from Microsoft Office365 SharePoint Support.

    Thanks for coming to the communities with your concerns about inviting external users.

    You were part way there. You did need to activate external user invitations however you also need to allow external users.

    Please follow these instructions to allow external users:

    1)      Log into your Microsoft Online Portal

    2)      Make sure the Admin tab is selected on the top of the screen

    3)      Under SharePoint Online, click Manage

    4)      In the Administration Center, click Manage Site Collections

    5)      Click settings dropdown, click Manage External Users

    6)      Change option to Allow

     

    Please let me know if this resolves your issue.

    I will continue to monitor this thread if you have any additional questions.

    Thanks,

     

    Jason Burnside

    Office 365 SharePoint Support

    1 out of 2 people found this post helpful.

  • Hello JMventures,

     

    Did you find the above post helpful in resolving your issue?

     

    I will continue to monitor this thread if you have any additional questions.

    Thanks,

     

    Jason Burnside

    Office 365 SharePoint Support

    1 out of 2 people found this post helpful.

  • I have followed these steps, but when I try click on 'site actions', then 'share site', I get a message "The groups required to manage users for your site are missing. You can either create them on your own as described here, or you can use advanced permissions to manage permissions for your site."

    I have created a group, but it does not allow me to add any external users to it.

  • Hello HollyC,

    Once the user accepts the invitation, the external user will be added to the group that you invited them through automatically. You should not have to add them to a group before.

    Did you delete the visitors and members groups? If so, please follow these instructions to add new groups to share the site:

    1. Click on the Site Actions dropdown, click on site settings
    2. Under Users and Permissions, Click Site Permissions
    3. Click Create Group
    4. Give a name and choose which permissions this group will have, click Create
    5. After the “.com/teamsite” add “/_layouts/permsetup.aspx” to the URL, click enter
    6. Choose the Use an existing group option and choose your created group
    7. Click OK
    8. Try to Share Site again

    You may have to do this for the Visitors and Members.

    Please let me know if this resolves your issue.

    I will continue to monitor this thread for further posts or questions.

    Thanks,

     

    Jason Burnside

    Office 365 SharePoint Support

    1 out of 1 people found this post helpful.

  • Jason, we've verified these steps, however, when the user we've invited attempts to log-in with a live id account, they get the following error:

     Microsoft Online Services is unavailable from this site for one of the following reasons:

    This site may be experiencing a problem

    The site may not be a member of the Windows Live Network

    You can:

    You can sign in or sign up at other Microsoft Online Services sites, or try again later at this site.

  • Hello ITonDemand,

    If a user is logged into Office 365 and a different user is trying to accept the invitation, from the same computer, it may cause this error? Is this what is happening?

    If so, please accept the invitation from a different computer.

    If not, they should add http://*.sharepoint.com, http://*.microsoftonline.com, https://*.outlook.com, https://*.lync.com, and http://www.<domain>.com to their Internet Explorer trusted sites.

    Please let me know if this resolves your issue.

    I will continue to monitor this thread for further posts or questions.

    Thanks,

     

    Jason Burnside

    Office 365 SharePoint Support

    1 out of 1 people found this post helpful.

  • Jason,

    Thank you for the reply.  We have verified these settings and users that have Live ID associated email addresses, still can not login as external users.  We have verified that we can successfully invite individuals with @hotmail.com addresses, however non @hotmail.com addresses can be invited but are unable to successfully log into sharepoint online.  Again, these are live id accounts, for example @gmail.com that can login at live.com.  Any additional advice?

  • Hello ITonDemand,

    I have sent you a private message so you may start a service request for your issue. Make sure that you check the link to the Private Messages as it may not register that you have one.

    I will continue to monitor this thread for further posts or questions.

    Thanks,

     

    Jason Burnside

    Office 365 SharePoint Support

    1 out of 1 people found this post helpful.

  • Hi, I have same problem. I can not add external user, even if I allow external users in Sharepoint Administration Center and change default groups of team sites according to your instruction. 



  • Hello Jan,

    To invite external users, you must have completed two different items when you have an Enterprise Subscription.

    1. Setting External Users in the Tenant Administration to Allow as you have already completed according to your screenshot
    2. Activating the External User Invitations feature

    To activate External User Invitations, please complete the following instructions:

     

    1. Log into Microsoft Online Portal
    2. Go to the Site that you would like to share
    3. Click on Site Actions
    4. Click on Site Settings
    5. Under Site Collection Administration menu, click Site Collection Features
    6. Activate the External User Invitations feature

     

    Please let me know if this resolves your issue.

    I will continue to monitor this thread if you have any additional questions.

    Thanks,

     

    Jason Burnside

    Office 365 SharePoint Support

    2 out of 2 people found this post helpful.

  • Thanks a lot. It works

Page 1 of 1 (12 items)