Sorry, you are not allowed to share this with external users.

  • 2 Followers
  • 5 Replies |
  • This post has 1 verified answer |
Answered (Verified) This question is answered

I have setup a site in office 365 SharePoint to share documents with clients. I have added 2 external users without problem, both of these uses have a @hotmail.com email address. I tried to add another external user with an email address @theredomain.com.au and I keep getting "Sorry, you are not allowed to share this with external users".

 

I have disable external sharing then re-enabled it to see if this helps, it didn't. When testing the setup I was able to add external users that had email addresses @theredomain.com.au, @gmail.com, etc. But now I can't what is the go?

 

We are in Australia on the Small Business Premium plan (P2).

 

This is important and need it resolved now.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  • Post Points: 20
Verified Answer
  • Hi Cdblind,

    I have found out what’s wrong with you. Currently, we can only direct share sites and documents to an external user who hasn’t been in your permission list. This means that you need to first invite the external users to your sites. After they accept the invitations, their profile will be recorded in the SharePoint permission list, then, you can share the document library to these external users.

    To meet your requirement, I suggest you first invite the external users to your site.

    Then, please go to Site Settings > Access requests and invitations to check whether the external users have accepted the invitation.

    After they accept the invitations, please share your document library with the external users.

    If the issue still persists after taking these actions, please feel free to let me know.

    Thanks,
    August

    • Top 50 Contributor
    • Post Points: 0
All Replies
  • Hi Cdblind,

    As I understand it, now you can’t share your site to the external users unless the users have a @hotmail.com address. I’d like to confirm whether you are sharing a document or the entire site to the external users.

    Could you please try going to Site Settings > Site permissions to check whether you can Grant Permissions to these external users? If the issue persists, the screenshots of the issue will be appreciated for further troubleshooting.

    Thanks,
    August

    • Top 50 Contributor
    • Post Points: 0
  • Hi August,

    I am trying to share document libraries with particular clients, when I tested it before going live it seemed to work exactly as I expected. However now that I have gone live it is not working, when I try to share the document library I get the following error:

     

    The only thing I can think of is maybe that in testing the external email address I used already had Microsoft account ID attached to them. But I though I did test it with one that had to sign up for a Microsoft account to access the share. But now I am not sure.

     

    Also I am trying to share only as 'Contributor"' but when the sharing fails it seem change back to 'Editor' rights

     

    Does the sharing feature check to see if the email address you want to share with has a Microsoft account ID before it will allow you to share with it?

    • Not Ranked
    • Post Points: 0
  • Hi August,

    I used another email address and signed up for a new Microsoft account ID, then I tried to share the document library again and failed with same error. So it is not a matter of needing a Microsoft account first.

    This all worked fine when I first set it up and was testing it, now when I try to use it with clients it is not working. Murphy's law what can go wrong will. Got love easy to use technology that is just supposed to work. No IT experience required :) lol

    • Not Ranked
    • Post Points: 0
  • Hi Cdblind,

    I have found out what’s wrong with you. Currently, we can only direct share sites and documents to an external user who hasn’t been in your permission list. This means that you need to first invite the external users to your sites. After they accept the invitations, their profile will be recorded in the SharePoint permission list, then, you can share the document library to these external users.

    To meet your requirement, I suggest you first invite the external users to your site.

    Then, please go to Site Settings > Access requests and invitations to check whether the external users have accepted the invitation.

    After they accept the invitations, please share your document library with the external users.

    If the issue still persists after taking these actions, please feel free to let me know.

    Thanks,
    August

    • Top 50 Contributor
    • Post Points: 0
  • Hi August

    That fixed it and it is now working, thank you for your help it is much appreciated.

    I would like to add that the process of sharing is pretty dumb, for years we have been working to introduce fine grained permissions so we can limit user access to only what they need, this seems to be a step backwards. It is very unlikely that I would ever want to share a whole team site with an external user, whether I am a large multi national company or a small one man operation. I would more likely only want to share parts of the site. While I can do this the process seems very convoluted not user friendly, it should be more difficult to share everything than it is to share small parts.

    Maybe Microsoft could work on this area, sharing with clients is very important but Office 365 is not Facebook clients do not need to know what I had for dinner last night.

    • Not Ranked
    • Post Points: 0
Page 1 of 1 (6 items)