No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Getting IP 2010 to work on everyone's computers - how is this done?

This question has suggested answer(s) This question has suggested answer(s)

We just switched over to O 365.  We have Infopath 2010.  I've been designing some forms and when I test them by posting them to a SP 2010 library, and then open the form online, the form opens in IP 2010 for me, where I can fill it out with no problems.

I've been testing this same form on colleagues' computers who also have O 365.  For almost all of them, the form did not work because they did not have version 14 (IP 2010) on their computer.  So I had to scramble by going back to the form and converting it back to a 2007 IP form.  After re-posting the form to the library, the form opened for them in IP 2007.

In my opinion, though, this should NOT be how it works.  If the company is paying for O 365, then EVERYONE should have IP 2010 on their computer.  More importantly, what do we need to do to get the newest version of IP on everyone's computer so they can easily fill out the forms I'm making for the company, and so that everything is consistent instead of scrambling and going back to 2007 IP?

Thanks.

1 out of 1 people found this post helpful.

All Replies
  • Hello Mike,
     
    I would like to confirm the following things:
    1. You are the administrator, right?
    2. Do you use Small Business plan (P plan)or Midsize business and enterprise plan(E plan)?
    3. Do you purchase subscriptions of Office Professional Plus for other users? Do you assign the very license to them?
     
    If your colleagues have been assigned the Office Professional Plus license, they can download and install it, then they can use Microsoft InfoPath 2010.
     
    For P plan, you can check whether you have purchased the Office Professional Plus subscriptions for all your colleagues. Otherwise, you can click Purchase under Subscriptions in the Admin page (portal.microsoftonline.com), and click Add to buy it which is paid for by per user license per month. Also, you can get a 30 day free trial by clicking Trial.
     
    Moreover, you can check whether you have assigned the license to your colleagues.
    Click Users in the Admin page, select the user and click Edit, and you can see whether the user has the license. If not,assign Office Professional Plus to the user.
     
    For E plan, you can also check if the Office Professional Plus license has been assigned to your colleagues. If not, assign Office Professional Plus to them.
     
    Then, the users assigned the Office Professional Plus license can login to Office 365 portal  (portal.microsoftonline.com) , click downloads in the right pane of the Home page, and click Install to download and install it.
     
    Office Professional Plus
     
    If there are any other questions about this issue, please feel free to post here.
     
    Thanks,
    Cherry Wang

    1 out of 1 people found this post helpful.

  • Hi Cherry - thanks for your reply.  I am the SharePoint admin at the company, however, I don't have full admin rights, which means I don't handle the part of running everyone's computers.  I just basically customize SharePoint for the company, make forms for them, offer business enterprise solutions, and so on.  I know this may be a strange answer to your question, but that's the way it's currently set up here.

     

    What I'm trying to do more than anything is design IP forms for company-wide use.  So that's why I'm frustrated because I designed this form only to find that every colleague desktop I went to (about 6 of them) all had IP 2007 open when they clicked on the ADD DOC link to open the form.  Originally, the form would not open at all on their computers because it was first published as a IP 2010 form; then I went back, converted it to IP 2007, and the form opened on their computers.  Only my desktop opened IP 2010 to fill out the form because I have IP 2010 installed.

     

    Anyway, here is my screen that you mention where you download:

     

     

    I guess what that means, and because I don't even know which 365 plan the company has, the only way to truly know what the company has bought into is by clicking on the Set up button and then letting the software load on their computers.  Is that correct?  Also, would you think that because I have IP 2010, does that sound to you as if we probably do have company-wide IP 2010 but no one has downloaded the software to their computers?

     

    Thanks, Mike

    1 out of 1 people found this post helpful.

  • Hi Mike,

    I would like to confirm with you the following things:
    1.You have three tabs on the top of the office 365 portal page, while you do not have the Admin page, right?
    2.Only you have InfoPath 2010, but from your screen shot, I find there is no Office Professional Plus to install. So, you may not download from Office 365, how did you install it?

    Moreover, I will appreciate your screenshot of Home page for further reasearch.

    Thanks,
    Cherry Wang

    1 out of 1 people found this post helpful.

  • 1. Right as I mentioned in my earlier post I don't have any admin rights.

    2.  When we got this, I asked the other admin about IP and he said you should have it so when I went to the IP 2007 files I designed before 365, they started opening in 2010.  My manager also asked me - before the company decided to go with 365 or not - to sign up for a 30-day trial of 365.  I went ahead and did that, so I'm wondering if IP 2010 opens because of this 30-day trial (which expired in May).

    1 out of 1 people found this post helpful.

  • Hello  Mike,

    You are right, the files created by InfoPath 2007 can be opened in InfoPath 2010, but the reverse can not.

    Meanwhile, I appreciate your screenshot of the Home page so that I can tell which plan you use, while I cannot tell from your Downloads screenshot.

    Thanks,
    Cherry Wang

    1 out of 1 people found this post helpful.

  • Hi Mike,

    How are things going? Is there any update about this issue?

    Thanks,
    Cherry Wang

    1 out of 1 people found this post helpful.

  • Yeah, I'm terribly frustrated.  As I mentioned I designed a grat IP file.  I only works when users who have the old version of IP on their computers - AND - when I revert the design from IP 2010 to IP 2007 so it works on their machines.

    Another thing I'm terribly frustrated with is every time I design a IP file, I also want to make it browser enabled.  However, when I try to do this, I keep getting the menu that says:

    This form is browser-compatible but not browser-enabled.

    Do you know how to fix this?

    1 out of 1 people found this post helpful.

  • Hi Mike,

    Based on the current situation, you can approximately check which plan you may be by following the steps:
    1.Login to Office 365 portal (portal.microsoftonline.com).
    2.In the Home page, if there are Office icons under Team site and  your public-facing website address under Website, you are a Small Business (P plan) user.
    If not, for example, only Visit SharePoint Home under Team site, you are an Enterprise (E plan) user.

    As for how to get InfoPath 2010 on your colleagues’ computers, which I have mentioned in the first reply, you can refer to the steps as below.
    To begin, you can contact your global administrator of Office 365 tenant for help with the actions.

    For P plan:
    •For how to get trial of Office Professional Plus:
    1.Login to Office 365 portal with global administrator credential.
    2.Click Purchase under Subscriptions in the left pane of Admin page.
    3.Click Trial under Office Professional Plus in the Purchase subscriptions page.
    •For how to assign Office Professional Plus license:
    1.Click Users in the Admin page.
    2.Select all the users except the administrator himself, click Edit.
    Then, if your administrator needs to use Office Professional Plus, he can select the administrator to edit it, assign Office Professional Plus license to himself.
    3.Click Next, click Next.
    4.Click Add to existing license assignments in the Assign licenses page, select Office Professional Plus, click Submit, and click Finish.

    For E plan:
    •For how to assign Office Professional Plus license:
    1.Login to Office 365 portal with global administrator credential.
    2.Click Users in the Admin page.
    3.Select all the users except the administrator himself, click Edit.
    Then, if your administrator needs to use Office Professional Plus, he can select the administrator to edit it, assign Office Professional Plus license to himself.
    4.Click Next, click Next.
    5.Click Add to existing license assignments in the Assign licenses page, select Office Professional Plus, click Submit, and click Finish.

    After that, the users can download and install Office Professional Plus:
    1.Login to Office 365 portal with their credential.
    2.Click Downloads in the right pane of Home page.
    3.Select Language and Version, and click Install. 

    As for This form is browser-compatible but not browser-enabled, if you use E plan, your global administrator can check the configuration about InfoPath Forms Services.
    1.Login to Office 365 portal with global administrator credential.
    2.Click Manage under SharePoint in the Admin page.
    3.Click Configure InfoPath Forms Services.
    4.Select these two:
    Allow users to browser-enable form templates
    Render form templates that are browser-enabled by users
    5.Click OK, and try again.

    If the issue persists after you follow the suggestions, please do not hesitate to post here.

    Thanks,
    Cherry Wang

    1 out of 1 people found this post helpful.

  • Cherry- thanks for this info.  Because I do not have the Office icons on my Home login page, it seem like I have the Enterprise (E) plan, right?  Can you send me a web link that lists the various features of the E plan?

     

    Also, see the image below.  Ideally, I'd like to publish an IP form that I designed so colleagues can fill it out in their browser.  But every time I try to publish a form for the browser, I get this menu message.  Can you tell me what I need to do so I can publish an IP form that colleagues can fill out in a browser? 

     

    Thanks.

     

    1 out of 1 people found this post helpful.

  • Hi Mike,
     
    Now that you ignored Cherry's requests for screen shot of your Office 365 Home page,should you contact your administrator to confirm which plan your company use? That's the simplest way to save time for both of you and Cherry.In addtion, for me,for the ones who have the same problem.
     
    I have to say that I really apprecaite Cherry's patience and efforts.
     
    For "form template can not be browser-enabled",Cherry has answered it in the last but one paragraph above.I agree with her.

    1 out of 1 people found this post helpful.

  • I didn't "ignore" Cherry.  I thought I posted a screenshot of my login home page way up at the top.  Here it is again:

     

     

    As for the IP web browser question, I will ask the global admin about the settings.  I'd like to keep this open.  I'm trying to follow up on this as much as possible - and would like to get it resolved - but there is a lot going on elsewhere.  Thanks for your assistance on this.

    1 out of 1 people found this post helpful.

  • Here is an update.  I asked the global admin to go in and look at the settings based on what cherry described above.  Here are the settings so it seems like our system is not working because browser enabled forms ARE enabled, but I cannot publish them to make them work for browser-enabled users.

     

    1 out of 1 people found this post helpful.

  • Cherry and other posters...

    One other thing I wanted to add to this thread.  After asking rhe global admin which plan we are on, he told me we're on E-1.  So hopefully this info, and the other two posts above, will help in resolving my issue.

    Thanks.

    1 out of 1 people found this post helpful.

  • Hi  Mike,

    Thanks for your information.

    Yes, your company uses E plan. And the configurations of User Browser-enabled Form Templates are right, those two should be enabled.

    You can refer to the following to check whether it works:
    1.Create a new form with InfoPath 2007, and try to publish it.
    2.Try to edit it with InfoPath 2010, and publish the current form.

    In addition, I find a similar issue with an answer in this link http://social.msdn.microsoft.com/forums/en-US/sharepointinfopath/thread/c9617953-a54c-44ec-86cf-df215c750c18 

    LuckyMars, thanks for your efforts.

    Thanks,
    Cherry Wang

    1 out of 1 people found this post helpful.

  • OK I'll work with the admin because I think it's going to be an Enterprise setting that needs to be adjusted.

    1 out of 1 people found this post helpful.